Profile Picture

Auto Setup 1.1 for Unity (Released on Sept 2nd)

Posted By Miranda (RL) Last Year
Rated 5 stars based on 1 vote.
Author
Message
Miranda (RL)
Miranda (RL)
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)

Group: Administrators
Last Active: 8 hours ago
Posts: 1.7K, Visits: 10.1K
Hello everyone,

Thanks for your patience. Auto Setup 1.1 for Unity officially releases on Sept. 2nd.
Here is the release note of Auto Setup 1.1:
  • Compatible with Unity 2019.1, 2019.2, 2019.3, Character Creator 3.3, iClone 7.8
  • Added: Support for CC3 Base+ characters
  • Enhanced: The Auto Setup only effects the file in the CC_Assets folder. (Reported by Necka)
  • Fixed: Merged material content exported as FBX and imported into Unity via Auto Setup tends to create empty materials without names. (FT #6460 reported by Scyra)
  • Fixed: The Auto Setup reverts animation changes even if the auto-processing is turned off. (Reported by sabrx)
  • Fixed: Skin material does not automatically assign the Diffusion profile for Unity 2019.1 Auto Setup. (Reported by gametuturiaisone, avalonsutra)
  • Fixed: Disabling Auto Setup and editing Character animation in Unity will cause an error.



--- The following is the outdated message posted in July ---

Hi everyone, 

We are currently fixing an issue on Auto Setup 1.1 for Unity, and plan to release next week.
Here is the release note of Auto Setup 1.1 for your reference first:
  • Compatible with Unity 2019.1, 2019.2, 2019.3, Character Creator 3.3, iClone 7.8
  • Support for CC3 Base+ characters
  • Fixed: Merged material content exported as FBX and imported into Unity via Auto Setup tends to create empty materials without names. (Feedback Tracker #6460 reported by Scyra)
  • Fixed: The Auto Setup reverts animation changes even the auto-processing is turned off. (Reported by sabrx)
If you'd like to test the Beta version, please send me a private message.


Many users reported different problems when using 2019.3 with Auto Setup v1.04 since June.
Here is the summary report of issues and our feedback, please check and let us know if there is further question, thank you!

Issue: Got wrong results with HDRP when importing characters with Traditional materials. (Reported by Jfrog)
Cause: Auto Setup supports HDRP, however, there is an issue when converting Traditional materials.
Workaround: Please convert all materials to PBR or Digital Human Shader in CC before export.

Issue: Some glowing white materials issues with characters (Reported by patrick.wheeler)
Cause: The "Embed Texture" option is checked.
Solution: Please untick the option and try again.  Refer to 01:45 of this tutorial.
https://www.youtube.com/watch?v=jUtC7sgh5s0?t=108

Issue: Character became green after importing to Unity (Reported by gametuturiaisone) -- fixed in v1.1
Cause: Diffuse profile isn't automatically assigned for skin; it displays as "None".
Workaround: We are still searching the solution to set diffuse profile via Unity C#, before it fixed, please manually set to the correct one.
https://forum.reallusion.com/uploads/images/85be0196-f839-49f3-b08a-2501.png

Issue: Character became black after importing to Unity (Reported by messer262a2)
We are unable to duplicate this issue on our side.
Please provide us console logs, check the video below, and follow every step. If the problem still remains, we may set a remote control call with you.


Issue: Character looks awful after importing to Unity (Reported by paulm_872026) 
We are unable to duplicate this issue, please provide us the ccProject and the entire FBX folder (contains mesh and texures)


Reallusion Team
Edited
Last Year by Miranda (RL)
duncan828
duncan828
Posted Last Year
View Quick Profile
New Member

New Member (13 reputation)New Member (13 reputation)New Member (13 reputation)New Member (13 reputation)New Member (13 reputation)New Member (13 reputation)New Member (13 reputation)New Member (13 reputation)New Member (13 reputation)

Group: Forum Members
Last Active: 3 days ago
Posts: 2, Visits: 26
Fix on the way sounds good and thanks for such an awesome tool.

Just to make sure all things are covered: When I use the Unity auto tool with the latest and greatest it more or less does work, but the SSS is a little bit over-zealous in comparison to the previous. See attached image. The 2 characters are 3.3 plus next to the previous 3.2, just default characters in T-Pose, auto imported (I manually set the diffusion profile, but its the same one for both) into Unity's HDRP, sample scene. So - default everything.
https://forum.reallusion.com/uploads/images/0f4038b5-c2a7-4691-8dbf-c952.jpg
Necka
Necka
Posted Last Year
View Quick Profile
Junior Member

Junior Member (180 reputation)Junior Member (180 reputation)Junior Member (180 reputation)Junior Member (180 reputation)Junior Member (180 reputation)Junior Member (180 reputation)Junior Member (180 reputation)Junior Member (180 reputation)Junior Member (180 reputation)

Group: Forum Members
Last Active: Last Month
Posts: 14, Visits: 131
Hello Miranda,

Sadly your PM inbox seem to be full but I'd like to try the auto setup tool v1.1 as it seem to fix most of the issues I've had
Jfrog
Jfrog
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (3.6K reputation)Distinguished Member (3.6K reputation)Distinguished Member (3.6K reputation)Distinguished Member (3.6K reputation)Distinguished Member (3.6K reputation)Distinguished Member (3.6K reputation)Distinguished Member (3.6K reputation)Distinguished Member (3.6K reputation)Distinguished Member (3.6K reputation)

Group: Forum Members
Last Active: 3 days ago
Posts: 529, Visits: 3.8K
@Miranda

Sadly your PM inbox seem to be full but I'd like to try the auto setup tool v1.1 


Hi Miranda,
Same here, can't reply to your PM. I would like to test it.

Thanks!



Intel I7 6850K 3.6 with MSI X99 SLI plus , GTX 1080,  32Gb Ram , 1 TB Samsung Pro M.2 SSD
Miranda (RL)
Miranda (RL)
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)

Group: Administrators
Last Active: 8 hours ago
Posts: 1.7K, Visits: 10.1K
Hi all,

Sorry, I didn't notice my mailbox is full.  I will contact you individually for the Beta. 
Thank you!

EdwS
EdwS
Posted Last Year
View Quick Profile
Veteran Member

Veteran Member (609 reputation)Veteran Member (609 reputation)Veteran Member (609 reputation)Veteran Member (609 reputation)Veteran Member (609 reputation)Veteran Member (609 reputation)Veteran Member (609 reputation)Veteran Member (609 reputation)Veteran Member (609 reputation)

Group: Forum Members
Last Active: Last Year
Posts: 22, Visits: 171
Hello,

I have a lot of issues with importing the characters, some of the textures are black and the hair is also not showing right. I have updated to 1.02 and use unity 2019.3

https://forum.reallusion.com/uploads/images/e2d8fcd0-3c9a-4b38-8f9d-af84.jpg
Miranda (RL)
Miranda (RL)
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)Distinguished Member (34.0K reputation)

Group: Administrators
Last Active: 8 hours ago
Posts: 1.7K, Visits: 10.1K
Hi Duncan,

Thanks for reporting this issue, we will fix it in the coming version.
Here is the workaround for reference after importing character into Unity. 
  1. Go to Assets > CC_Resource > Texture > Skin > G3Plus
  2. Select "Head_Thickness"
  3. Uncheck "sRGB"
  4. Click Apply to save the change.

duncan828 (7/26/2020)
Fix on the way sounds good and thanks for such an awesome tool.

Just to make sure all things are covered: When I use the Unity auto tool with the latest and greatest it more or less does work, but the SSS is a little bit over-zealous in comparison to the previous. See attached image. The 2 characters are 3.3 plus next to the previous 3.2, just default characters in T-Pose, auto imported (I manually set the diffusion profile, but its the same one for both) into Unity's HDRP, sample scene. So - default everything.
https://forum.reallusion.com/uploads/images/0f4038b5-c2a7-4691-8dbf-c952.jpg


FabricioAlencar
FabricioAlencar
Posted Last Year
View Quick Profile
New Member

New Member (25 reputation)New Member (25 reputation)New Member (25 reputation)New Member (25 reputation)New Member (25 reputation)New Member (25 reputation)New Member (25 reputation)New Member (25 reputation)New Member (25 reputation)

Group: Forum Members
Last Active: Last Month
Posts: 3, Visits: 112
Great news BigGrin
michael.pickering
michael.pickering
Posted Last Year
View Quick Profile
Junior Member

Junior Member (147 reputation)Junior Member (147 reputation)Junior Member (147 reputation)Junior Member (147 reputation)Junior Member (147 reputation)Junior Member (147 reputation)Junior Member (147 reputation)Junior Member (147 reputation)Junior Member (147 reputation)

Group: Forum Members
Last Active: Last Month
Posts: 37, Visits: 191
I'd very much like to test the beta Auto Setup but one of the CC3 features that I need to use is the ability to add logos to clothing using a "Decal". Unfortunately, this isn't working in CC3.3 at all!

It now looks like I'll need to uninstall CC 3.3 and re-install CC 3.2 to get this feature working. Any advise as to which version of the Auto Setup might work with FBX exported from CC 3.2 and Unity (preferably 2019.3) HDRP?
deidrereaystudios
deidrereaystudios
Posted Last Year
View Quick Profile
Senior Member

Senior Member (368 reputation)Senior Member (368 reputation)Senior Member (368 reputation)Senior Member (368 reputation)Senior Member (368 reputation)Senior Member (368 reputation)Senior Member (368 reputation)Senior Member (368 reputation)Senior Member (368 reputation)

Group: Forum Members
Last Active: 9 days ago
Posts: 30, Visits: 228
I would like to test the beta.. Our company uses CC3 for our games and are still dead in the water after updating to the newest cc3 etc... Is there any eta on when the new auto setup will be working correctly and released??? If not soon please and thank would like to test the betas..



Reading This Topic