Profile Picture

Mouth Open on Daz Character from CC3 to Unity

Posted By cloud.ninja Last Year
You don't have permission to rate!
Author
Message
cloud.ninja
cloud.ninja
Posted Last Year
View Quick Profile
Junior Member

Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)

Group: Forum Members
Last Active: Last Week
Posts: 7, Visits: 68
I followed the tutorial found here: https://forum.reallusion.com/397639/Special-Notice-FAQ-for-CCUnity-AutoSetup-Script and was able to get my Daz character imported from CC3 into Unity.

My new challenge is that with applying an animation, the character has it's mouth hanging open. See attached file "MouthOpenBug"

My animation works with other imported Unity characters but not Gen 3 or 8 - it leaves the mouth open. When I go to configure the CC_Base_JawRoot to another bone - after I click Done & Apply - it reverts back to the CC_Base_JawRoot?! (see image)  When I go to Muscles & Settings, I can use the Open close slide bar under Muscle Group Preview and but when I try to close the mouth using Jaw Close under the Per-Muscle Setting - nothing happens?! (see image). 

I've also tried closing the mouth using blendshapes but it won't close the mouth all the way. 

I'm not able to script in Unity either. Any ideas to resolve?

with appreciation,
cn

Attachments
MouthOpenBug.PNG (88 views, 217.00 KB)
CC_Base_JawRoot.PNG (61 views, 28.00 KB)
Muscles and Settings.PNG (54 views, 160.00 KB)
Miranda (RL)
Miranda (RL)
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)

Group: Administrators
Last Active: 13 hours ago
Posts: 1.0K, Visits: 7.0K
Hi cloud.ninja, 
May I know if you turned off the "Auto-Processing" before adjusting the bone?
thanatopsis
thanatopsis
Posted Last Year
View Quick Profile
New Member

New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)New Member (17 reputation)

Group: Forum Members
Last Active: 5 Months Ago
Posts: 2, Visits: 135
I've had that "mouth open" problem in Unity with a variety of 3D figured (DAZ, Mixamo, Reallusion) and different character rigs (Unity, Invector, Ootii 3rd-person controllers). I used to be able to fix it by editing the face bones in Unity and selecting "none" for the jaw bone. That stopped working recently for some reason, maybe in Unity 2018.2 or 2018.3. I finally got sick of it and edited all my animation files. I looked at the animations in Unity from the drop-down menu WIndow > Animation > Animation and "Animator.Jaw Close" = 0 on all my offending animations. I have to change the start and end points to equal 1. The only problem is most animations are read-only, so I have to find the correct animation (easier on a new project as there aren't 25 Idle and Run animations), select it, and copy it with control-D (command-D on Mac) then rename it to something like Jaw-Idle or Jaw-Run. Then I make Animator.Jaw Close = 1 and then drag that into the Animator motion parameters to replace the old one. On the plus side, I added an "out of breath" idle pose after a sprint with the mouth opening and closing.
I had to do that for a few dozen animations, but it works for now for my simple running/jumping game. I don't know if there is an easy way to use Layers or something to make one closed jaw state and make it overlay all the other animations. If anybody has any better ideas, let me know.
cloud.ninja
cloud.ninja
Posted Last Year
View Quick Profile
Junior Member

Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)

Group: Forum Members
Last Active: Last Week
Posts: 7, Visits: 68
Thanatopsis - Thank you for your reply - I also couldn't set the jaw bone to "none". I will try your workflow - much appreciated.
Edited
Last Year by cloud.ninja
cloud.ninja
cloud.ninja
Posted Last Year
View Quick Profile
Junior Member

Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)

Group: Forum Members
Last Active: Last Week
Posts: 7, Visits: 68
Miranda (RL) - Thank you for your reply - where is that option?
Edited
Last Year by cloud.ninja
Miranda (RL)
Miranda (RL)
Posted 5 Months Ago
View Quick Profile
Distinguished Member

Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)

Group: Administrators
Last Active: 13 hours ago
Posts: 1.0K, Visits: 7.0K
cloud.ninja (12/31/2018)
Miranda (RL) - Thank you for your reply - where is that option?


https://forum.reallusion.com/uploads/images/ede62715-536b-4a01-91a7-2a73.png
rjhayle
rjhayle
Posted 4 Months Ago
View Quick Profile
Junior Member

Junior Member (238 reputation)Junior Member (238 reputation)Junior Member (238 reputation)Junior Member (238 reputation)Junior Member (238 reputation)Junior Member (238 reputation)Junior Member (238 reputation)Junior Member (238 reputation)Junior Member (238 reputation)

Group: Forum Members
Last Active: 3 Months Ago
Posts: 16, Visits: 202
It's a bit of a strange one this. The default in Unity is 0 and when you look at the jaw this equals to a half open mouth. So you have to edit your read-only animations and set the Animator.Jaw Close = 1, like previously stated by thanatopsis.

>May I know if you turned off the "Auto-Processing" before adjusting the bone?

I tried this and it made no difference. I noticed that when you untick the checkbox, close the window and open the window again the checkbox is set to true again.
Is this a bug?
Edited
4 Months Ago by rjhayle
Miranda (RL)
Miranda (RL)
Posted 4 Months Ago
View Quick Profile
Distinguished Member

Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)

Group: Administrators
Last Active: 13 hours ago
Posts: 1.0K, Visits: 7.0K
rjhayle (2/17/2019)
It's a bit of a strange one this. The default in Unity is 0 and when you look at the jaw this equals to a half open mouth. So you have to edit your read-only animations and set the Animator.Jaw Close = 1, like previously stated by thanatopsis.

>May I know if you turned off the "Auto-Processing" before adjusting the bone?

I tried this and it made no difference. I noticed that when you untick the checkbox, close the window and open the window again the checkbox is set to true again.
Is this a bug?

This is a bug as you described. 
We have fixed this issue, and it's under verification now.
Before the updated version release, please keep the window open when do any adjustment.

We also noticed that the mouth will be open when the character stays still, and will be close right when there is animation.
There is no further thing the auto-setup script can do at the moment. If there is more information, we will let you know.
angelin.sirbu
angelin.sirbu
Posted 3 Months Ago
View Quick Profile
New Member

New Member (98 reputation)New Member (98 reputation)New Member (98 reputation)New Member (98 reputation)New Member (98 reputation)New Member (98 reputation)New Member (98 reputation)New Member (98 reputation)New Member (98 reputation)

Group: Forum Members
Last Active: Last Month
Posts: 3, Visits: 92
I have the exact same issue with the default CC3 settings. My character is the default male exported.

Is there any ETA on the fix?

Also, I cannot find the face blendshapes in the rigidbody.
Miranda (RL)
Miranda (RL)
Posted 3 Months Ago
View Quick Profile
Distinguished Member

Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)Distinguished Member (18.4K reputation)

Group: Administrators
Last Active: 13 hours ago
Posts: 1.0K, Visits: 7.0K
angelin.sirbu (3/13/2019)
I have the exact same issue with the default CC3 settings. My character is the default male exported.

Is there any ETA on the fix?

We'd like to clarify if this is the case you encountered.
https://forum.reallusion.com/uploads/images/56b60183-f0a6-4288-a5dc-9731.png

There is no motion file exported along with FBX file, which means there is no animation in the Animation Controller. When clicking play, we will see this result.
If this is the case you encounter, you can manually delete the Animation Controller, or add animation. 

 Also, I cannot find the face blendshapes in the rigidbody.

he question of blendshape location has been answered by a forum user, please visit your original post for details.
https://forum.reallusion.com/407209/Export-blend-shapes-for-faces-in-Unity 



Reading This Topic