Profile Picture

Why does Preview never have any Shadow Artifacts?

Posted By Strife Last Year
You don't have permission to rate!
Author
Message
Strife
Strife
Posted Last Year
View Quick Profile
Senior Member

Senior Member (353 reputation)Senior Member (353 reputation)Senior Member (353 reputation)Senior Member (353 reputation)Senior Member (353 reputation)Senior Member (353 reputation)Senior Member (353 reputation)Senior Member (353 reputation)Senior Member (353 reputation)

Group: Forum Members
Last Active: 4 days ago
Posts: 10, Visits: 304
Anyone know why the Preview mode with iRay render never seems to show any artifacts - shadows look great... but then when you do an actual render (with Eliminate Shadow Artifact ON) the artifacts show up consistently?

Is there a setting Preview has enabled that we can match in the final render settings?
animagic
animagic
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (20.7K reputation)Distinguished Member (20.7K reputation)Distinguished Member (20.7K reputation)Distinguished Member (20.7K reputation)Distinguished Member (20.7K reputation)Distinguished Member (20.7K reputation)Distinguished Member (20.7K reputation)Distinguished Member (20.7K reputation)Distinguished Member (20.7K reputation)

Group: Forum Members
Last Active: 12 hours ago
Posts: 11.9K, Visits: 20.8K
It might be helpful if you post images of Preview and render. Otherwise it's hard to determine what's going on.


https://forum.reallusion.com/uploads/images/1a09220f-ab50-42ac-ad1a-33ec.pnghttps://forum.reallusion.com/Uploads/Images/d14339d0-cd32-4b35-88f9-40a0.png


3dtester
3dtester
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 485, Visits: 1.0K
I experience the same issue, ever since i'm using Iray in iClone.
The shadows in the final MI render often don't look smooth.
They have hard edges and sometimes also 'artifacts'.
In preview mode, the shadows always look good.

I have too posted a thread about this a while ago, but never got any replies...
https://forum.reallusion.com/402039/iray-shadow-hardness

https://forum.reallusion.com/uploads/images/ba9e0376-e995-4328-aaa6-d777.png

I never found a way to fix these shadows in iClone.



System: Xeon E5-1650v2 @3.5 GHz (6-core), 32 GB, GTX-1080Ti

Edited
Last Year by 3dtester
animagic
animagic
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (20.7K reputation)Distinguished Member (20.7K reputation)Distinguished Member (20.7K reputation)Distinguished Member (20.7K reputation)Distinguished Member (20.7K reputation)Distinguished Member (20.7K reputation)Distinguished Member (20.7K reputation)Distinguished Member (20.7K reputation)Distinguished Member (20.7K reputation)

Group: Forum Members
Last Active: 12 hours ago
Posts: 11.9K, Visits: 20.8K
It's been a while, but as I recall the size of the light sources influences the quality of the shadows in Iray.

For every light sources used you can change the size in the Iray settings and this will change the sharpness or softness of the shadows. 


https://forum.reallusion.com/uploads/images/1a09220f-ab50-42ac-ad1a-33ec.pnghttps://forum.reallusion.com/Uploads/Images/d14339d0-cd32-4b35-88f9-40a0.png


4u2ges
4u2ges
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)

Group: Forum Members
Last Active: 12 hours ago
Posts: 2.0K, Visits: 7.8K
First, there are some issues with MI render compare to Preview, but I have never experienced any issues with shadows. Screenshots please?

Second, Animagic is correct. Shadows softness depends on light source shape and it can be tweaked in Lights tab of Iray settings.

Finally, when it comes to purely IBL light, there is no way to control shadows other than tweaking the IBL image itself (or transforming it).
Yes, IBL does not cast shadows in iClone, but physically accurate Iray would cast shadows from any source including IBL.

@3dtester IBL normally produces very soft shadows with Iray. That makes me wonder what kind of IBL image you used to have such harsh shadows?
Also can you look at the Lights tab in Iray settings to see if there is nothing else listed as a light source?

I can't get anything sharper than this with IBL (which is fairly soft IMO):

https://forum.reallusion.com/uploads/images/1334f1c0-9d20-4484-9407-b4cc.jpg





Edited
Last Year by 4u2ges
3dtester
3dtester
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 485, Visits: 1.0K
Well, you are right, i used an additional light for that scene. But only because Iclone IBL doesn't cast shadows.
I should have checked the Iray settings for that light source...

But i have a small example from a recent render test (IBL only).
The images are cropped to the neccessary section Wink

Preview render:

https://forum.reallusion.com/uploads/images/696af74a-4e7a-4488-a308-01be.png

MI render:

https://forum.reallusion.com/uploads/images/11a5a283-5463-46f1-a470-1122.png



System: Xeon E5-1650v2 @3.5 GHz (6-core), 32 GB, GTX-1080Ti

Edited
Last Year by 3dtester
4u2ges
4u2ges
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)

Group: Forum Members
Last Active: 12 hours ago
Posts: 2.0K, Visits: 7.8K
Oh wow! Let me check...




4u2ges
4u2ges
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)

Group: Forum Members
Last Active: 12 hours ago
Posts: 2.0K, Visits: 7.8K
Yep, appears to be a bug. The attribute string "shadow_terminator_offset_mode" "on" is present in the MI export.
However, it seems to be OFF regardless. And I am afraid it is one of those NVIDIA bugs cases.

Another example:
https://forum.reallusion.com/uploads/images/a7bbac7f-4256-4ad6-946a-e91d.jpg
https://forum.reallusion.com/uploads/images/edf2cba8-ae8a-4cc7-a79b-8f87.jpg

You guys may want to open an FT issue. Otherwise I'll try to do it later on.



I just want to stress how important it is to report such problems to RL in the Feedback tracker.
We might have gotten some answers from RL 3 month ago.





Edited
Last Year by 4u2ges
4u2ges
4u2ges
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)

Group: Forum Members
Last Active: 12 hours ago
Posts: 2.0K, Visits: 7.8K
Found temporary solution. Apparently one other attribute is missing in the MI export (for the case when "Eliminate Shadow Artifacts" is checked):

attribute boolean "shadow_terminator_offset" true

Inserting this attribute into scene options section of the MI export fixes the problem. This is definitely an RL bug.

https://forum.reallusion.com/uploads/images/c1bef7a2-1d04-44e8-8981-1d63.jpg




UPDATE: FT 6162   "Eliminate Shadow Artifact" does not work with MI Export



Edited
Last Year by 4u2ges
3dtester
3dtester
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)Distinguished Member (1.9K reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 485, Visits: 1.0K
Thanks a lot for taking care of that issue, 4u2ges.
I hope RL will fix it in the next update (without waiting for enough votes...)




System: Xeon E5-1650v2 @3.5 GHz (6-core), 32 GB, GTX-1080Ti




Reading This Topic