Why does Preview never have any Shadow Artifacts?


https://forum.reallusion.com/Topic413477.aspx
Print Topic | Close Window

By 4u2ges - 2 Years Ago
Yep, appears to be a bug. The attribute string "shadow_terminator_offset_mode" "on" is present in the MI export.
However, it seems to be OFF regardless. And I am afraid it is one of those NVIDIA bugs cases.

Another example:
https://forum.reallusion.com/uploads/images/a7bbac7f-4256-4ad6-946a-e91d.jpg
https://forum.reallusion.com/uploads/images/edf2cba8-ae8a-4cc7-a79b-8f87.jpg

You guys may want to open an FT issue. Otherwise I'll try to do it later on.



I just want to stress how important it is to report such problems to RL in the Feedback tracker.
We might have gotten some answers from RL 3 month ago.

By 3dtester - 2 Years Ago
Thanks a lot for taking care of that issue, 4u2ges.
I hope RL will fix it in the next update (without waiting for enough votes...)

By justaviking - 2 Years Ago
@4u2ges - You, sir, are a beast!  Your ability to dig into the inner workings of Iray is unrivaled.  Thanks, again, for your excellent detective work.  Smile
By 4u2ges - 2 Years Ago
No problem, I am pretty sure they would fix it for the next release.Wink
By Peter (RL) - 2 Years Ago
4u2ges (8/10/2019)

I just want to stress how important it is to report such problems to RL in the Feedback tracker.
We might have gotten some answers from RL 3 month ago.



Thanks for the great detective work 4u2ges. Smile

I also want to reiterate what 4u2ges has said. It is vital that bugs and issues are reported in the Feedback Tracker and not just posted on the forum where they may be missed.
By 4u2ges - 2 Years Ago
Here is an update on the issue +.

I have found out there is difference in MI scene rendering depending on the method used for execution.
BTW: this is not the first time such a discrepancy have been discovered.

All is good if you Drag and Drop scene file onto the  Batch Renderer executable.
But I hate Drag and Drop and never use it. Instead I have made an .mi file association with IrayStandaloneRenderer.exe

So when I double click scene file and fire up renderer, at least 2 discrepancies could be observed (there might be more):

1. Shadow artifacts are not removed.
2. At the end, when message pops up asking to open file, there is NO button to open a log file.

I did verify that my file association is correct and even if I use "Open With* from context menu and navigate to the executable, it still does render with 2 problems mentioned above.

FT ticket was updated....


UPDATE:
Apparently where was an issue with file associations in Windows 10. it was pointing the older version of the Batch Renderer.
And even when I picked the right executable in "Open With", it would revert to the old one on the fly. I LOVE Microsoft!
After cleaning the .mi association in registry and recreating it all is working fine now.



By Strife - 2 Years Ago
Anyone know why the Preview mode with iRay render never seems to show any artifacts - shadows look great... but then when you do an actual render (with Eliminate Shadow Artifact ON) the artifacts show up consistently?

Is there a setting Preview has enabled that we can match in the final render settings?
By 3dtester - 2 Years Ago
I experience the same issue, ever since i'm using Iray in iClone.
The shadows in the final MI render often don't look smooth.
They have hard edges and sometimes also 'artifacts'.
In preview mode, the shadows always look good.

I have too posted a thread about this a while ago, but never got any replies...
https://forum.reallusion.com/402039/iray-shadow-hardness

https://forum.reallusion.com/uploads/images/ba9e0376-e995-4328-aaa6-d777.png

I never found a way to fix these shadows in iClone.
By 4u2ges - 2 Years Ago
First, there are some issues with MI render compare to Preview, but I have never experienced any issues with shadows. Screenshots please?

Second, Animagic is correct. Shadows softness depends on light source shape and it can be tweaked in Lights tab of Iray settings.

Finally, when it comes to purely IBL light, there is no way to control shadows other than tweaking the IBL image itself (or transforming it).
Yes, IBL does not cast shadows in iClone, but physically accurate Iray would cast shadows from any source including IBL.

@3dtester IBL normally produces very soft shadows with Iray. That makes me wonder what kind of IBL image you used to have such harsh shadows?
Also can you look at the Lights tab in Iray settings to see if there is nothing else listed as a light source?

I can't get anything sharper than this with IBL (which is fairly soft IMO):

https://forum.reallusion.com/uploads/images/1334f1c0-9d20-4484-9407-b4cc.jpg

By 4u2ges - 2 Years Ago
FT 6162   "Eliminate Shadow Artifact" does not work with MI Export now has "Released in 7.6" status.

Sorry to report but it was only half fixed.
Indeed, when running "Render Scene" with "Stand Alone Render (save mi scene)", artifacts are getting smoothed out in the rendered image.
However, if I turn around and initiate the render again from the Export folder, or use just "Save Mi Scene" and then render, artifacts are still there.

Looks like that parameter is passed *softly* into the render routine, but is NOT hard-coded into the Exported scene file.

New FT 6232 "Eliminate Shadow Artifact" is only partially fixed in IC7.6
By animagic - 2 Years Ago
It might be helpful if you post images of Preview and render. Otherwise it's hard to determine what's going on.
By animagic - 2 Years Ago
It's been a while, but as I recall the size of the light sources influences the quality of the shadows in Iray.

For every light sources used you can change the size in the Iray settings and this will change the sharpness or softness of the shadows. 
By 4u2ges - 2 Years Ago
Found temporary solution. Apparently one other attribute is missing in the MI export (for the case when "Eliminate Shadow Artifacts" is checked):

attribute boolean "shadow_terminator_offset" true

Inserting this attribute into scene options section of the MI export fixes the problem. This is definitely an RL bug.

https://forum.reallusion.com/uploads/images/c1bef7a2-1d04-44e8-8981-1d63.jpg




UPDATE: FT 6162   "Eliminate Shadow Artifact" does not work with MI Export
By 4u2ges - 2 Years Ago
Thank you guys Smile
By 4u2ges - 2 Years Ago
Oh wow! Let me check...
By 3dtester - 2 Years Ago
Well, you are right, i used an additional light for that scene. But only because Iclone IBL doesn't cast shadows.
I should have checked the Iray settings for that light source...

But i have a small example from a recent render test (IBL only).
The images are cropped to the neccessary section Wink

Preview render:

https://forum.reallusion.com/uploads/images/696af74a-4e7a-4488-a308-01be.png

MI render:

https://forum.reallusion.com/uploads/images/11a5a283-5463-46f1-a470-1122.png