Profile Picture

iClone character fingers get distorted when imported in Unity

Posted By thanosxanderian 2 Years Ago
You don't have permission to rate!

iClone character fingers get distorted when imported in Unity

Author
Message
thanosxanderian
Problem.png
thanosxanderian
Posted 2 Years Ago
View Quick Profile
Senior Member

Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 13, Visits: 57
I created a simple character animation in iClone that looks like this:

https://forum.reallusion.com/uploads/images/9ff1641d-aa28-4a45-9b2b-b622.png

However, when I export this character using 3dxchange to Unity an preview animation, the fingers of the character are distorted. Here is how it looks in Unity:

https://forum.reallusion.com/uploads/images/02597dde-a769-42ec-b722-8568.png

As you can see in the above picture, the fingers of the character, especially the thumb, index and middle finger, are not the same to those in the iClone.
How can I solve this issue? What are the possible causes?
Thanks in advance.
Edited
2 Years Ago by thanosxanderian
Snarp Farkle
Snarp Farkle
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (3.5K reputation)Distinguished Member (3.5K reputation)Distinguished Member (3.5K reputation)Distinguished Member (3.5K reputation)Distinguished Member (3.5K reputation)Distinguished Member (3.5K reputation)Distinguished Member (3.5K reputation)Distinguished Member (3.5K reputation)Distinguished Member (3.5K reputation)

Group: Forum Members
Last Active: 2 Weeks Ago
Posts: 724, Visits: 3.1K
I'd be interested in the answer for this as well, I'm still a ways off from my iClone to Unity workflow but gathering all the info I can to help elevate problems in advance.


Dell XPS 8900, Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz, 3408 Mhz, 4 Core(s), 8 Logical Processor(s), 16 GB RAM, - 4 GB GeForce GTX 745, NVIDIA compatible.
Acer Aspire V Nitro Laptop,  2.5GHz Intel Core i5-7300HQ processor with 6MB cache,  256GB solid state drive, 16GB Ram,  4 GB NVIDIA GeForce GTX 1050 Ti graphics.

vidi
vidi
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (22.5K reputation)Distinguished Member (22.5K reputation)Distinguished Member (22.5K reputation)Distinguished Member (22.5K reputation)Distinguished Member (22.5K reputation)Distinguished Member (22.5K reputation)Distinguished Member (22.5K reputation)Distinguished Member (22.5K reputation)Distinguished Member (22.5K reputation)

Group: Forum Members
Last Active: 7 hours ago
Posts: 10.3K, Visits: 35.5K
look  in the unity quality setting if blend weights is set to 4 bones

-------------------------------------------------------------------
liebe Grüße vidi
http://vididoll.de/1grafik/promoforum.png




thanosxanderian
thanosxanderian
Posted 2 Years Ago
View Quick Profile
Senior Member

Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 13, Visits: 57
vidi (5/12/2017)
look  in the unity quality setting if blend weights is set to 4 bones

Yes, it is set to 4. Should it be changed ?
vidi
vidi
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (22.5K reputation)Distinguished Member (22.5K reputation)Distinguished Member (22.5K reputation)Distinguished Member (22.5K reputation)Distinguished Member (22.5K reputation)Distinguished Member (22.5K reputation)Distinguished Member (22.5K reputation)Distinguished Member (22.5K reputation)Distinguished Member (22.5K reputation)

Group: Forum Members
Last Active: 7 hours ago
Posts: 10.3K, Visits: 35.5K
Yes, it is set to 4. Should it be changed ?
No  4 is right 
I created a simple character animation
if it is an animation , In the Unity screen it shows frame 0 maybe your right pose i on another frame ? 


-------------------------------------------------------------------
liebe Grüße vidi
http://vididoll.de/1grafik/promoforum.png




thanosxanderian
thanosxanderian
Posted 2 Years Ago
View Quick Profile
Senior Member

Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)Senior Member (367 reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 13, Visits: 57
I found that the problem was  when I imported the character to Unity the rig setup I set was Humanoid. However, after changing it to Generic everything works fine. I initially made the rig setup Humanoid by following iClone tutorials online. Apparently, that doesn't seem to work, at least in my case.
'
uchey.mioneshy
uchey.mioneshy
Posted Last Year
View Quick Profile
Junior Member

Junior Member (193 reputation)Junior Member (193 reputation)Junior Member (193 reputation)Junior Member (193 reputation)Junior Member (193 reputation)Junior Member (193 reputation)Junior Member (193 reputation)Junior Member (193 reputation)Junior Member (193 reputation)

Group: Forum Members
Last Active: Last Year
Posts: 2, Visits: 10
Hi! It works for me! I can't say any word for this. After a week try to change anything ( including animations>mask and transform, reimport 3d models, etc) I changed to generic back. Thanks!

thanosxanderian (5/16/2017)
I found that the problem was  when I imported the character to Unity the rig setup I set was Humanoid. However, after changing it to Generic everything works fine. I initially made the rig setup Humanoid by following iClone tutorials online. Apparently, that doesn't seem to work, at least in my case.
'





Reading This Topic