Profile Picture

Character Creator constantly 'deleting' files

Posted By gekido 4 Months Ago
You don't have permission to rate!
Author
Message
gekido
gekido
Posted 4 Months Ago
View Quick Profile
Senior Member

Senior Member (404 reputation)Senior Member (404 reputation)Senior Member (404 reputation)Senior Member (404 reputation)Senior Member (404 reputation)Senior Member (404 reputation)Senior Member (404 reputation)Senior Member (404 reputation)Senior Member (404 reputation)

Group: Forum Members
Last Active: 3 Weeks Ago
Posts: 36, Visits: 137
What's up with this? I work on a file and after doing exports, pushing to iClone or what-have-you the actual CCProject files somehow get deleted? I've started managing them in a version control system so I can restore backups but this is horrific behaviour for a program like this?

Related: why does the project end up being 'temp.ccProject' after doing a push from CC to IClone? In what world would this ever be what you want as a user? 


Something, something #Realtime #madewithunity 
Prior projects: Baymax Dreams, Adam Ep2/3 etc.
Side project: http://dystopiawars.com - turn-based cyberpunk RPG
gekido
gekido
Posted 4 Months Ago
View Quick Profile
Senior Member

Senior Member (404 reputation)Senior Member (404 reputation)Senior Member (404 reputation)Senior Member (404 reputation)Senior Member (404 reputation)Senior Member (404 reputation)Senior Member (404 reputation)Senior Member (404 reputation)Senior Member (404 reputation)

Group: Forum Members
Last Active: 3 Weeks Ago
Posts: 36, Visits: 137
As a follow up - this isn't some 'random' thing that happened once - it happens ALL OF THE TIME. I can have a project open, be doing some work on it, and then randomly when I try to save, the file that I opened is GONE and I'm suddenly saving a brand new file to disk. 

It's very obviously a bug in the save system (or auto save system? does CC do auto saves?) because every time this happens I end up with a file:

__RL_Save_File_.Temp

in the same directory - so obviously something went wrong with the save and this file didn't get copied back onto the original file. 

Something, something #Realtime #madewithunity 
Prior projects: Baymax Dreams, Adam Ep2/3 etc.
Side project: http://dystopiawars.com - turn-based cyberpunk RPG
Peter (RL)
Peter (RL)
Posted 4 Months Ago
View Quick Profile
Distinguished Member

Distinguished Member (79.8K reputation)Distinguished Member (79.8K reputation)Distinguished Member (79.8K reputation)Distinguished Member (79.8K reputation)Distinguished Member (79.8K reputation)Distinguished Member (79.8K reputation)Distinguished Member (79.8K reputation)Distinguished Member (79.8K reputation)Distinguished Member (79.8K reputation)

Group: Administrators
Last Active: 2 hours ago
Posts: 19.3K, Visits: 30.1K
gekido (6/26/2021)
It's very obviously a bug in the save system (or auto save system? does CC do auto saves?) because every time this happens I end up with a file:

__RL_Save_File_.Temp

in the same directory - so obviously something went wrong with the save and this file didn't get copied back onto the original file. 


I'm sorry to hear you are having these problems but I don't think it is a bug with the software otherwise it would affect everyone. I personally have never had this issue and we are not seeing any other reports of this issue so it is more likely a system specific problem.

You also mention temp folders and files which by their very nature they are intended to be temporary and are deleted at the end of your current session. The normal way to save your project is to click the + ADD button at the bottom of Content Manager and the project will be saved automatically in the correct custom folder. Never save anything in a Temp folder. Once a project is saved it can then be re-loaded from Content Manager when required.

You can find out more about how to save in Content Manager using the link below.

https://manual.reallusion.com/Character_Creator_3/ENU/3/Content/Character_Creator_3/3/04_Introducing_the_User_Interface/Content_manager.htm


                                                                

Peter
Forum Administrator

www.reallusion.com


OvO_4550
OvO_4550
Posted 2 Months Ago
View Quick Profile
New Member

New Member (65 reputation)New Member (65 reputation)New Member (65 reputation)New Member (65 reputation)New Member (65 reputation)New Member (65 reputation)New Member (65 reputation)New Member (65 reputation)New Member (65 reputation)

Group: Forum Members
Last Active: Last Month
Posts: 3, Visits: 23
I am having this exact same issue. All same symptoms. This happens to every project I work on in CC3. I start them all the same, create a new project and save it to a file on my data drive which is a physically separate hard drive than the drive CC3 is installed to (not in the temp folders), and they disappear during the course of working on it. I didn't catch this last night when I saved and closed my project for the night only to find it missing when I went back in and in it's place is the _RL_Save_File_.Temp file. So, yeah, have to redo a couple hours of work from the backup version I made earlier.
Peter (RL)
Peter (RL)
Posted 2 Months Ago
View Quick Profile
Distinguished Member

Distinguished Member (79.8K reputation)Distinguished Member (79.8K reputation)Distinguished Member (79.8K reputation)Distinguished Member (79.8K reputation)Distinguished Member (79.8K reputation)Distinguished Member (79.8K reputation)Distinguished Member (79.8K reputation)Distinguished Member (79.8K reputation)Distinguished Member (79.8K reputation)

Group: Administrators
Last Active: 2 hours ago
Posts: 19.3K, Visits: 30.1K
OvO_4550 (8/30/2021)
I am having this exact same issue. All same symptoms. This happens to every project I work on in CC3. I start them all the same, create a new project and save it to a file on my data drive which is a physically separate hard drive than the drive CC3 is installed to (not in the temp folders), and they disappear during the course of working on it. I didn't catch this last night when I saved and closed my project for the night only to find it missing when I went back in and in it's place is the _RL_Save_File_.Temp file. So, yeah, have to redo a couple hours of work from the backup version I made earlier.


Have you tried saving your project by simply clicking the + ADD button at the bottom of Content Manager (see below). This will save the project file to your custom library where you have a thumbnail available to load it at any time. I have never lost a project file using this method.

Please Note: Your Custom library is saved in the location you set during install. This does not have to be the C: drive and can be any drive you wish.

https://forum.reallusion.com/uploads/images/813cd8db-2e07-4839-8821-06b6.jpg


                                                                

Peter
Forum Administrator

www.reallusion.com





Reading This Topic