Profile Picture

Animations are all borked once imported to Unity - following the tutorials and have pipeline...

Posted By juliein3d Last Year
You don't have permission to rate!

Animations are all borked once imported to Unity - following the...

Author
Message
juliein3d
juliein3d
Posted Last Year
View Quick Profile
New Member

New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)

Group: Forum Members
Last Active: 5 Months Ago
Posts: 13, Visits: 58
I make my character in CC, I export it to iClone, I'm animating well in iClone, just what I want body movement and lipsync, use the collection line, send first the character, then the character with the animations to 3DXchange and then export as exactly prescribed in the tutorials from 3DXchange - pick Unity, turn off mesh, etc. I always set all things as headed toward Unity in the dialog boxes, ..However, my animation is 100% borked in Unity, that crazy polygon thing happens during the animation.  As in even if I move the play head to line up the green dots as suggested in the unity it is just more crazy.  I can get the character into Unity by doing the .fbx export out of iClone7 but that doesn't move the animation so really I'm lost here on this.  Feel like I'm following the pipeline to the letter but weeks of trying and bork, bork!  I do the whole make it humanoid part so that isn't the issue.  I was wondering about frame rate but seems ok there set to 30, I've checked that I'm picking Unity every time...kind of out of what to try to find my mistake.

The moment I get to the animation selected and try the polygons go crazy.  I wonder if this is some obvious thing I'm doing wrong.  Clearly I am missing something on this so wondering if someone can advise.

.I've attached some snaps to see if they help.  Thanks for any insight.https://forum.reallusion.com/uploads/images/2ae54fb7-ec92-48ad-8f70-766b.pnghttps://forum.reallusion.com/uploads/images/2c6c4c13-b2a2-4fa9-a8b0-0a17.png
juliein3d
juliein3d
Posted Last Year
View Quick Profile
New Member

New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)

Group: Forum Members
Last Active: 5 Months Ago
Posts: 13, Visits: 58
BTW I have all the latest and all are pipeline.  In case that is a wonder.
Scyra
Scyra
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)

Group: Forum Members
Last Active: 4 Months Ago
Posts: 220, Visits: 2.5K
You have CC3 Pipeline? If so, you should try CC3's FBX export with Include Motion and use the Unity auto-setup script. You can optionally export just the motion without the character from there as well.



CC3 & Daz Tricks | CC3 to Unity workflow

juliein3d
juliein3d
Posted Last Year
View Quick Profile
New Member

New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)

Group: Forum Members
Last Active: 5 Months Ago
Posts: 13, Visits: 58
But I'm doing lipsync and body movement in iClone 7 so I don't think you can do that in CC.  So I can get the character in from CC, from iClone, and from 3DXchange.  In fact the .fbx export is great in iClone.  But maybe you are saying to export from CC and that will make the iClone created and collected aminations work properly?  I can try it, will try anything.  Need this working.    So far my even though I do that setting of the curves to be green in Unity, the incoming aninations from iClone on the character created in CC originally break my characters into wildly flung polygons when I try to use them.  I don't mind using one tool for the character and a different tool for the animations, think I've tried each combo so there must be 1 or more settings i'm wrong with, but can't find it.  Keep feeling like this is an axis issue but I'm following the directions (trying to) and setting to  Unity exports, etc.
Any thoughts?
Scyra
Scyra
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)

Group: Forum Members
Last Active: 4 Months Ago
Posts: 220, Visits: 2.5K
You should be able to save out your iMotion files to your hard drive and then there is a place to attach them during the CC to Unity export process.

I did notice something strange in Unity now that you mention it...

https://forum.reallusion.com/uploads/images/c48b9ebd-8a17-43c8-a438-bc4b.png

Edit: After some testing, this does not seem to be the cause of any problems with imported animations.



CC3 & Daz Tricks | CC3 to Unity workflow

Edited
Last Year by Scyra
juliein3d
juliein3d
Posted Last Year
View Quick Profile
New Member

New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)

Group: Forum Members
Last Active: 5 Months Ago
Posts: 13, Visits: 58
I have also found that when I use Convert to Gamebase in CC under Modify Attributes that I cannot get the export to iClone via iAvatar to work, it just does nothing when I do the File>Export>iAvatar selection for iClone.   
I was reducing with InstaLOD then moving it to Gamebase as I'm targeting phones so was trying to go as low polygon as possible.    I don't know if there is some rule here about what cannot be used if your pipeline-ing CC to iClone.

Maybe this is part of the issue but just hunting around in the dark a little as a newbie.  I think I need some insights on how "low" I can go on polygons or what the fixed max and mins are in this area.  

juliein3d
juliein3d
Posted Last Year
View Quick Profile
New Member

New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)New Member (72 reputation)

Group: Forum Members
Last Active: 5 Months Ago
Posts: 13, Visits: 58
For now I gave up trying to reduce and am doing all of it in iClone and using iClone FBX export and directly dragging it into Unity.   Seems working but my characters are not optimized from CC into iClone so have to find out more about this.



Reading This Topic