Profile Picture

Create Morph Slider Fails

Posted By Lord Ashes Last Year
You don't have permission to rate!
Author
Message
Lord Ashes
Lord Ashes
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)

Group: Forum Members
Last Active: Last Month
Posts: 1.2K, Visits: 1.4K
I am trying to create a Morph Slider for CC3 characters.
I opened CC3, reset the default character and then used the CC3 Export Nude option to get a CC3 OBJ file along with the ObjKey file.
I then opened the CC3 OBJ file, modified some vertices location (did not remove or add anything new) and saved as a new OBJ file.
This is the same process I used in CC2 and was successful.
However, in CC3 I keep getting a "OBJ file or decryption key corrupted" error.
I am using the same software that I did in CC2 which created valid OBJ files. 

https://forum.reallusion.com/uploads/images/426b4f21-35b8-4044-9637-478d.png

Any ideas what might be wrong?

"We often compare ourselves to the U.S. and often they come out the best, but they only have the right to walk on the grass while we have the right to smoke it"
Lord Ashes' Original
animagic
animagic
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)

Group: Forum Members
Last Active: 5 hours ago
Posts: 11.3K, Visits: 19.6K
I have successfully created a couple of morphs using the same method, except that I didn't use the default character but a converted DAZ character (via the Transformer). I will try with the default character and see what happens.

UPDATE: I have no problem with the Default CC3 character either. What software do you use? Tonight I used Argile 2, but before that I used 3D Coat.


https://forum.reallusion.com/uploads/images/1a09220f-ab50-42ac-ad1a-33ec.pnghttps://forum.reallusion.com/Uploads/Images/d14339d0-cd32-4b35-88f9-40a0.png


Edited
Last Year by animagic
Lord Ashes
Lord Ashes
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)

Group: Forum Members
Last Active: Last Month
Posts: 1.2K, Visits: 1.4K
animagic (11/13/2018)

UPDATE: I have no problem with the Default CC3 character either. What software do you use? Tonight I used Argile 2, but before that I used 3D Coat.

I am using an ancient piece of software, Anim8or, for most of my work. Any FBX work (which isn't necessary in this case) I do via Blender. I have used the Anim8or software to create all of the content in my content store (usually using Blender just for rigging clothing to a skeleton) including my CC2 morph sliders which worked fine. I have a hard time believing that something in CC3 doesn't like the Anim8or output since it accepted it in CC2 and looking at the OBJ file there does not seem to be anything out of the ordinary.

At some point I will have to take the time to learn Blender properly but over the years I have learned how to overcome most of the limitations of Anim8or and have my work flows established. And I do love the fact that it is a single file (no install) with no dependencies and is less than 5MB in size! (No that is not a typo...the previous version fit on to a floppy disk...if people still remember what that is). 


"We often compare ourselves to the U.S. and often they come out the best, but they only have the right to walk on the grass while we have the right to smoke it"
Lord Ashes' Original
Edited
Last Year by Lord Ashes
Lord Ashes
Lord Ashes
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)

Group: Forum Members
Last Active: Last Month
Posts: 1.2K, Visits: 1.4K
I just did the same process in pure Blender and got the same result.

1. Export CC3 character using CC3's "Export | OBJ (Nude Character)" option. Ths generated an OBJ and ObjKey file.
2. Open OBJ file in Blender.
3. Modify mesh (all I did was scale a bunch of points)
4. Save modified OBJ file
5. In CC3, Create Morph Slider (using the same settings shown in the previous screen capture).

Same error occurs...as such it is not related to my ancient software (since this test workflow did not use it at all).

"We often compare ourselves to the U.S. and often they come out the best, but they only have the right to walk on the grass while we have the right to smoke it"
Lord Ashes' Original
4u2ges
4u2ges
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)

Group: Forum Members
Last Active: 6 hours ago
Posts: 1.7K, Visits: 7.0K
Does not work for me either. With Default character it says "The base and target characters are incompatible".
With older CC2 base in CC3 it is working, but the result is horrific. Parts of the body which were untouched in Blender and now sort of inflated.

The worst part is, that it does the same now in CC2 (which used to work fine)! Even if I export to OBJ and immediately bring it back as a morph slider it does this:

https://forum.reallusion.com/uploads/images/6fc2f3cc-0905-4cf8-bd1c-5a6d.jpg

Just what a heck? Anyone else is having this problem or it is just my CC2 and CC3 installations got messed up?








animagic
animagic
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)

Group: Forum Members
Last Active: 5 hours ago
Posts: 11.3K, Visits: 19.6K
Something that was reported in another thread is that CC3 morphs (if you are able to create them) are incompatible with iClone's Morph Creator. 


https://forum.reallusion.com/uploads/images/1a09220f-ab50-42ac-ad1a-33ec.pnghttps://forum.reallusion.com/Uploads/Images/d14339d0-cd32-4b35-88f9-40a0.png


4u2ges
4u2ges
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)

Group: Forum Members
Last Active: 6 hours ago
Posts: 1.7K, Visits: 7.0K
What am I doing wrong?






Lord Ashes
Lord Ashes
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)

Group: Forum Members
Last Active: Last Month
Posts: 1.2K, Visits: 1.4K
4u2ges (11/14/2018)
What am I doing wrong?




At least you got the morph to import...I get an error during the import. Worked fine in CC2 but CC3 sees to have issues. It also seems that my previously working CC2 morphs no longer work correctly in CC3.



"We often compare ourselves to the U.S. and often they come out the best, but they only have the right to walk on the grass while we have the right to smoke it"
Lord Ashes' Original
4u2ges
4u2ges
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)

Group: Forum Members
Last Active: 6 hours ago
Posts: 1.7K, Visits: 7.0K
At least you got the morph to import...I get an error during the import. Worked fine in CC2 but CC3 sees to have issues. It also seems that my previously working CC2 morphs no longer work correctly in CC3.


Lord, it is not a morph in any way. And I cannot import it either after customizing obj in Blender.
I suppose you guys realized what happened in the video. I applied the very SAME obj to morph slider right after exporting.
And it did inflate the character, when there is nothing supposed to happen.
Exactly the same behavior in CC2 now.





Edited
Last Year by 4u2ges
animagic
animagic
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)

Group: Forum Members
Last Active: 5 hours ago
Posts: 11.3K, Visits: 19.6K
@4u2ges: I had to apply to the Current Morph instead of the Default Morph for the morph to work correctly. You would think the default character is the default morph but apparently not...Unsure

EDIT: Also, I think Lord Ashes means that he is not able to import an OBJ file at all and get an OBJ key error. At least you could import the OBJ file without problems.


https://forum.reallusion.com/uploads/images/1a09220f-ab50-42ac-ad1a-33ec.pnghttps://forum.reallusion.com/Uploads/Images/d14339d0-cd32-4b35-88f9-40a0.png


Edited
Last Year by animagic



Reading This Topic