Profile Picture

PBR materials

Posted By gmach5 Last Year
You don't have permission to rate!
Author
Message
gmach5
gmach5
Posted Last Year
View Quick Profile
Junior Member

Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)

Group: Forum Members
Last Active: Last Year
Posts: 4, Visits: 74
I'm using Iclone vs. 7.3.  When applying a PBR material the shader maps change to the selected material but do not appear on the prop on the screen.  I have PBR turned on for the project and defaults applied and PBR selected for shader type in the modify panel.  The manual does not indicate anything else to do and can't find a forum topic for problem.  What am I doing wrong or need to do?
Kelleytoons
Kelleytoons
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)

Group: Forum Members
Last Active: 3 hours ago
Posts: 5.9K, Visits: 11.8K
Do they render?



Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
justaviking
justaviking
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (15.2K reputation)Distinguished Member (15.2K reputation)Distinguished Member (15.2K reputation)Distinguished Member (15.2K reputation)Distinguished Member (15.2K reputation)Distinguished Member (15.2K reputation)Distinguished Member (15.2K reputation)Distinguished Member (15.2K reputation)Distinguished Member (15.2K reputation)

Group: Forum Members
Last Active: 9 hours ago
Posts: 7.5K, Visits: 22.9K
What is your Preview "quality" setting set to?
https://forum.reallusion.com/uploads/images/00134bc4-3ba2-4f24-8ab8-2285.jpg




iClone 7... Character Creator... Substance Designer/Painter... Blender... Audacity...
Desktop (homebuilt) - Windows 7, i7-3770k CPU, GTX 1080 GPU (8GB), 16GB RAM, Asus P8Z77-V Pro motherboard, 500 GB SSD, terabytes of disk space, dual  monitors.
Laptop - Windows 10, MSI GS63VR STEALTH-252, 16GB RAM, GTX 1060 (6GB), 256GB SSD and 1TB HDD

gmach5
gmach5
Posted Last Year
View Quick Profile
Junior Member

Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)

Group: Forum Members
Last Active: Last Year
Posts: 4, Visits: 74
Thank you both Kellytoon and Justavinking.  After hours and hours of trying to get this to work, this is what I found out:
Every material has two files: a .PNG file and a .SBSAR file.  I failed to see this before.
On medium setting this is what happens using the 2 file formats:
.PNG files:     Does change screen view
                       does NOT change maps
                       does NOT render
.SBSAR files:  does NOT change screen view
                        Does change maps
                        Does render
On high setting the files act as following:
.PNG does not change screen, does not change maps, does not render
.SBSAR changes screen, maps and renders
Lesson: Work on high setting for each object then switch to medium.  Problem: screen view reverts to previous established maps when switching to medium. Seems like this creates a nightmare workflow situation.  You have to check every single object to make sure it is right before rendering or have to render multiple times to correct errors.  Or, never use medium which negates the purpose of having it and having PNG files.
Thank you very much for your help.  Took two full days to figure out one demonstrated material change in a beginners tutorial. At least I got it to work and learned how to use the forum.  Hope this helps others.

Kelleytoons
Kelleytoons
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)

Group: Forum Members
Last Active: 3 hours ago
Posts: 5.9K, Visits: 11.8K
PNG files should work and should be reflected in screen view, at least in high mode (I never work in any other mode).  Can you post a sample where this does not?

https://forum.reallusion.com/uploads/images/1696cc7a-70c7-4e03-a6f3-6d2f.png




Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
4u2ges
4u2ges
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 1.7K, Visits: 7.0K
Every material has two files: a .PNG file and a .SBSAR file.  I failed to see this before.
On medium setting this is what happens using the 2 file formats:
.PNG files:     Does change screen view
                       does NOT change maps
                       does NOT render


You mean this .png file?
https://forum.reallusion.com/uploads/images/7d02656c-47c2-424e-a130-cba2.jpg

It is not a material. It merely a shortcut to an icon, which should not be there in the first place.
To avoid confusion do not assign materials from the PACK tab.
Use MEDIA tab instead, where Substance is listed by the materials type and does not include png icons.

https://forum.reallusion.com/uploads/images/eb343077-4964-4dda-8ba5-e3a2.jpg


As to quality control, it directly relates to the "Real-time render options" in "Preferences".
You can have "Medium" up and then manually check what you need to see in real-time.
Once you override a default real-time options, it tuns into "Custom"

https://forum.reallusion.com/uploads/images/07b2871d-fb09-4639-8b27-0ba3.jpg





Edited
Last Year by 4u2ges
gmach5
gmach5
Posted Last Year
View Quick Profile
Junior Member

Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)Junior Member (192 reputation)

Group: Forum Members
Last Active: Last Year
Posts: 4, Visits: 74
Thanks all. I think I got it. The material PNG file is basically a thumbnail with the working real file being Sbsar.  Turning off high resolution reverts the scene to the base original png file which would conserve resources.  Final quality checks would always be done in HIGH and all renders would be in HIGH. Using the media files prevents the confusion.  I can live with all of that.  Had to go back and forth a lot to figure it out with your direction.  Thank you.  Kelleytoons I was never able to get a png file to show in the high setting but as I learn more will probably get there.  I would like to put thongs on everything as you were able to do. 



Reading This Topic