Profile Picture

Can't get Faceware to work in Motion LIVE

Posted By Kelleytoons Last Year
You don't have permission to rate!
Author
Message
Kelleytoons
Kelleytoons
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)

Group: Forum Members
Last Active: 2 hours ago
Posts: 5.9K, Visits: 11.9K
Here's a video showing my problem (sent to support but just in case some smart folks here can spot what the issue might be):






Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
Peter (RL)
Peter (RL)
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)

Group: Administrators
Last Active: Yesterday
Posts: 16.0K, Visits: 24.1K
Hi KT,

With Faceware Realtime selected in the Gear List, go to the Character List and select the Face option (the triangle) and it should show a dropdown. Just select Faceware Realtime and it should connect.

https://forum.reallusion.com/uploads/images/510747cc-b3a7-4197-af0f-8723.jpg


                                                                

Peter
Forum Administrator

www.reallusion.com


Kelleytoons
Kelleytoons
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)

Group: Forum Members
Last Active: 2 hours ago
Posts: 5.9K, Visits: 11.9K
No, that doesn't work, Peter.






Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
Edited
Last Year by Kelleytoons
Peter (RL)
Peter (RL)
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)

Group: Administrators
Last Active: Yesterday
Posts: 16.0K, Visits: 24.1K
In your video you are trying to select "Faceware Live". You need to ensure that "Faceware Realtime" is selected in the Gear List first (has a solid green circle). It looks like you removed that option from the Gear List in the first video which is why it is no longer shown.

https://forum.reallusion.com/uploads/images/73e9098d-fb64-45d9-a9fe-8e4a.png



                                                                

Peter
Forum Administrator

www.reallusion.com


Edited
Last Year by Peter (RL)
Kelleytoons
Kelleytoons
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)

Group: Forum Members
Last Active: 2 hours ago
Posts: 5.9K, Visits: 11.9K
Hmmm, I could have SWORN I tried "Faceware Realtime" when I first got this setup, and then I removed it because it didn't work and so I thought the "Live" was corresponding to the "LIVE" of Motion.  That almost has to be the problem, though, since others aren't having any issues.

I'll try again (but it IS confusing that the two are named so -- Realtime is Live and Live is not LIVE, I guess :>Wink.



Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
Kelleytoons
Kelleytoons
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)

Group: Forum Members
Last Active: 2 hours ago
Posts: 5.9K, Visits: 11.9K
Okay, that does work.  Thanks, Peter, I'll remove it from my trouble ticket.



Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
TonyDPrime
TonyDPrime
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)

Group: Forum Members
Last Active: 1 hour ago
Posts: 1.7K, Visits: 5.5K
KT - I also saw in your video that you didn't have the "Avoid Poor Performance" mode selected in the Troubleshooting tab of the LeapMotion controller, perhaps that is leading to some of the jitter you were seeing in the hands.  Kai mentions you want to have this selected 'on' in the video.  Also, in the vid Kai does address the upside down palm thing, but I don't remember exactly what he says, but it is in that video...

But at least you have it working, I just have nothing with the LeapMotion still Ermm


Peter (RL)
Peter (RL)
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)Distinguished Member (52.1K reputation)

Group: Administrators
Last Active: Yesterday
Posts: 16.0K, Visits: 24.1K
Great to hear you got it sorted now. Smile

                                                                

Peter
Forum Administrator

www.reallusion.com


Kelleytoons
Kelleytoons
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)Distinguished Member (19.0K reputation)

Group: Forum Members
Last Active: 2 hours ago
Posts: 5.9K, Visits: 11.9K
TonyDPrime (6/6/2018)
KT - I also saw in your video that you didn't have the "Avoid Poor Performance" mode selected in the Troubleshooting tab of the LeapMotion controller, perhaps that is leading to some of the jitter you were seeing in the hands.  Kai mentions you want to have this selected 'on' in the video.  Also, in the vid Kai does address the upside down palm thing, but I don't remember exactly what he says, but it is in that video...


Actually, in the video he says to NOT have that checkmarked (what he says is something like "we don't need to worry about this as we can easily fix this later".  I assume by "we" he means "our crack team of engineers who have far more time than you ever would").  I don't remember him saying anything about the hands down thing other than if you have desktop versus head mounted you need to have the right one selected (which I do).  Trust me, I've watched that video dozens of times before I even bought this (thinking, "wow, it works so great!"  I have since revised my opinion :>Wink.

I truly think the biggest issue is that they (and by "they" I mean RL, who obviously NEVER uses anyone other than in-house betas who don't try anything that a real user would) used a head mounted display.  Either that or they were VERY careful on how they pressed the spacebar.  As another user noted here, once you move your arm in a different position and THEN press that spacebar that motion is added to the arms (as it's re-positioned back normally).  This HAS to result in uneven hands -- no way around it.  I find I can get it "better" if I'm really careful about this, but what we really need is just a short "countdown" (even two seconds would work) to allow us to get our arms in the right position.  Again, lack of real testing on this stuff, which frustrates me no end.





Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
TonyDPrime
TonyDPrime
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)

Group: Forum Members
Last Active: 1 hour ago
Posts: 1.7K, Visits: 5.5K
Kelleytoons (6/6/2018)
TonyDPrime (6/6/2018)
KT - I also saw in your video that you didn't have the "Avoid Poor Performance" mode selected in the Troubleshooting tab of the LeapMotion controller, perhaps that is leading to some of the jitter you were seeing in the hands.  Kai mentions you want to have this selected 'on' in the video.  Also, in the vid Kai does address the upside down palm thing, but I don't remember exactly what he says, but it is in that video...


Actually, in the video he says to NOT have that checkmarked (what he says is something like "we don't need to worry about this as we can easily fix this later".  I assume by "we" he means "our crack team of engineers who have far more time than you ever would").  I don't remember him saying anything about the hands down thing other than if you have desktop versus head mounted you need to have the right one selected (which I do).  Trust me, I've watched that video dozens of times before I even bought this (thinking, "wow, it works so great!"  I have since revised my opinion :>Wink.

I truly think the biggest issue is that they (and by "they" I mean RL, who obviously NEVER uses anyone other than in-house betas who don't try anything that a real user would) used a head mounted display.  Either that or they were VERY careful on how they pressed the spacebar.  As another user noted here, once you move your arm in a different position and THEN press that spacebar that motion is added to the arms (as it's re-positioned back normally).  This HAS to result in uneven hands -- no way around it.  I find I can get it "better" if I'm really careful about this, but what we really need is just a short "countdown" (even two seconds would work) to allow us to get our arms in the right position.  Again, lack of real testing on this stuff, which frustrates me no end.



So I saw your response and checked the video and you are absolutely right, he says to have it off.  I got excited and ran back into iClone to see if it work with the mode unchecked....And.............
No dice Crying
Also tried reinstalling both LeapMotion and MotionLive Plugin, but nada.

I wish I too had findings and could concur...I mentally can, but not in practice Angry



Reading This Topic