Profile Picture

Seamless walk cycle in iclone

Posted By karl.trolenberg 3 Years Ago
You don't have permission to rate!
Author
Message
karl.trolenberg
karl.trolenberg
Posted 3 Years Ago
View Quick Profile
Junior Member

Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 10, Visits: 49
I am using iclone 7 and have a question about creating seamless walk cycles. I have a puppet clip of a character walking that I created in motion puppet. I want  to be able to save out the clip to use on other characters. When I loop the clip the characters end pose doesn't match up seamlessly with the beginning. How can I fix this?
Kelleytoons
Kelleytoons
Posted 3 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)

Group: Forum Members
Last Active: 5 hours ago
Posts: 6.8K, Visits: 14.1K
If you set a key at the start of the cycle and then copy this same key to the very end you ought to be able to end up with something "seamless".



Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
karl.trolenberg
karl.trolenberg
Posted 3 Years Ago
View Quick Profile
Junior Member

Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 10, Visits: 49
I am fairly new to iclone. Would I be adding a key in the motion layer? As of now the add key button is grayed out.

Thanks
Kelleytoons
Kelleytoons
Posted 3 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)

Group: Forum Members
Last Active: 5 hours ago
Posts: 6.8K, Visits: 14.1K
You need to select whatever layer you are going to key, and then the add key will be available.  And, yes, it will be the motion layer.



Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
karl.trolenberg
karl.trolenberg
Posted 3 Years Ago
View Quick Profile
Junior Member

Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 10, Visits: 49
Even after selecting the motion layer the add key button is grayed out. Selecting the puppet clip doesn't work either.
Kelleytoons
Kelleytoons
Posted 3 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)

Group: Forum Members
Last Active: 5 hours ago
Posts: 6.8K, Visits: 14.1K
I have to go out to the doctor right now but if no one else has helped you when I get back I'll post a screen shot or something.



Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
karl.trolenberg
karl.trolenberg
Posted 3 Years Ago
View Quick Profile
Junior Member

Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 10, Visits: 49
Thanks for your help!
mark
mark
Posted 3 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (8.7K reputation)Distinguished Member (8.7K reputation)Distinguished Member (8.7K reputation)Distinguished Member (8.7K reputation)Distinguished Member (8.7K reputation)Distinguished Member (8.7K reputation)Distinguished Member (8.7K reputation)Distinguished Member (8.7K reputation)Distinguished Member (8.7K reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 4.1K, Visits: 12.0K
I'm using iClone 7.1 and did a Motion Puppet basic walk with Christian. I found the "looping" point at about frame 85. I "right-clicked" on the clip in the layer and used the "Break" command, deleted the rest of the animation on the layer then used the "loop" function to repeat the clip in the layer and had a pretty good looping walk. You could then collect the "Main" animation clip without the extended loops you made and save it and use it with other avatars. I could be wrong but  I think this is what you are trying to do.


PROMO-BACK2
Click here to go to my YouTube Channel filled with iClone Tutes and Silly Stuff

Visit ANIMATED PROJECTIONS Powered by iCLONE

Intel Core i7 3960X @ 3300MHz Overclocked to 4999.7 MHz Sandy Bridge 24.0GB DDR3 @ 833MHz Graphic Display HP ZR30w 
GeForce GTX 980Ti 6GB  Microsoft Windows 7 Professional 64-bit SP1 ASUSTeK COMPUTER INC. P9X79 WS (LGA2011)



Keith_MPS
Keith_MPS
Posted 3 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)

Group: Forum Members
Last Active: Last Week
Posts: 377, Visits: 1.2K
I posted a response in your other thread on this topic:
https://forum.reallusion.com/349466/Seamless-walk-cycle-in-ICLONE-7

It includes a few things to look at, including breaking the clip as Mark has done.

- Keith
karl.trolenberg
karl.trolenberg
Posted 3 Years Ago
View Quick Profile
Junior Member

Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 10, Visits: 49
I will try breaking the clip. I only worry it will be hard to get the exact pose and it may look like a blip in the loop.

I am used to 3ds max where I would just duplicate the key frames from the beginning to the end. I guess there is no comparable solution here.

Thanks



Reading This Topic