Profile Picture

(A solution) Rendering Large Projects 3 Million Poly+ -On Export iClone Crashes

Posted By Ascensi 2 Years Ago
You don't have permission to rate!

(A solution) Rendering Large Projects 3 Million Poly+ -On Export...

Author
Message
Ascensi
Ascensi
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (1.6K reputation)Distinguished Member (1.6K reputation)Distinguished Member (1.6K reputation)Distinguished Member (1.6K reputation)Distinguished Member (1.6K reputation)Distinguished Member (1.6K reputation)Distinguished Member (1.6K reputation)Distinguished Member (1.6K reputation)Distinguished Member (1.6K reputation)

Group: Forum Members
Last Active: Last Month
Posts: 74, Visits: 541
I had to share this with everyone because the information wasn't available to me in any tutorial or manual.. I had come to a realization.
iClone has it's own rendering built in and is not needed when exporting -it just sucks up all of your resources displaying the scene and chokes the resources needed to export large projects.
Steps for optimization
1.Set iClone to use the quick shader or less (if there is a less)
2. Set the displacement on your models to 0 and then once imported into Indigo set them to your original values.
3. Make sure your hard drive(s) have a lot of Virtual memory - I set mine up  from 3k to 40k max -for Audio projects/DAW the opposite is true for stability.
4. Having Solid state hard drive speeds things up a bit.. USB HDs require more memory. Creating the Indigo project files on a simple USB HD only allowed saving at 128 MB/s where as the SSD allowed it 256-512 Mb.
5. Most may already know this but disabling any non essential program running in the background can speed things up as well as prevent crashes.
I think it would be good that Reallusion adds a switch in iClone to lower the quality of all features when export is pressed or at least update the manual with performance & stability procedures.. I spent a lot of time wondering what was wrong with the project, iClone or Indigo. I contacted Reallusion's support and was told to keep everything set to max quality for final render -so wrong when using Indigo instead of iClone's render system.. it's Indigo Render where the quality is to be manufactured from, we just need to get our files there!



| i7 -4790K 4.0GHz | 32 GB | GeForce RTX 2080 Ti 11GB | GTX 970 x4 | Window10 | Zbrush 2018 & Keyshot | Maya 2014 | Adobe CS6 | Sonar Producer X3 | iClone Pro & 3D Exchange Pipeline 7 | DTS Master Audio Suite | Perception Neuron 32 Alum Edition | Akeytsu
https://forum.reallusion.com/uploads/images/2181b17f-1a5f-4475-a14b-4dbe.gif
Everything here was modeled in Zbrush, Rigged in Akeytsu, animated in iClone 7 and Rendered in Indigo Render 3X   - Fully Noobed, no years of experience, must have vision and drive -completely oblivious to time.
Scene was almost 3 Million polygons. Since it wasn't covered in any tutorials or the manual I learned the hard way..  Set iClone to use quick shader and set any displacement to 0 when exporting to Indigo Project files. Enable any displacement levels in Indigo.   

Edited
2 Years Ago by Ascensi
SeanMac
SeanMac
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (2.4K reputation)Distinguished Member (2.4K reputation)Distinguished Member (2.4K reputation)Distinguished Member (2.4K reputation)Distinguished Member (2.4K reputation)Distinguished Member (2.4K reputation)Distinguished Member (2.4K reputation)Distinguished Member (2.4K reputation)Distinguished Member (2.4K reputation)

Group: Forum Members
Last Active: 2 days ago
Posts: 351, Visits: 2.8K
Thanks for the tip, Ascensi
freerange
freerange
Posted 2 Years Ago
View Quick Profile
Veteran Member

Veteran Member (814 reputation)Veteran Member (814 reputation)Veteran Member (814 reputation)Veteran Member (814 reputation)Veteran Member (814 reputation)Veteran Member (814 reputation)Veteran Member (814 reputation)Veteran Member (814 reputation)Veteran Member (814 reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 165, Visits: 437
nice work, you need to have progressive renders though, the interlacing is making things look wonky. Pretty much you never need to render interlaced video anymore.

Free Range
My IMDB



Reading This Topic