Profile Picture

Base and Target characters are incompatible

Posted By television_99 2 Years Ago
You don't have permission to rate!
Author
Message
television_99
television_99
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 104, Visits: 734
Problem making morph slider in Character Creator

Fairly new to CC... BUT.... I've created new morph sliders successfully in the recent past. Now, this is baffling. Below are the steps I took this time

1. From CC, morphed character to where I liked it
2. From CC, exported quad Obj
3. From Zbrush imported and sculpted character
4. From ZBrush Exported character as quad mesh Obj
5. From CC tried to make morph slider but get "Base and Target characters are incompatible" message..used obj-key and morph obj.
https://forum.reallusion.com/uploads/images/acc28e61-775d-469b-be58-1378.jpg

television_99
television_99
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 104, Visits: 734
I think it has to do with deleting the teeth and eyes, I'm perhaps conflating how I imported in 3DXchange and CC. The one I imported/morphed into CC didn't have teeth and eyes like it was supposed to.

I'll double check but I need to take a little break .
television_99
television_99
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)Distinguished Member (2.1K reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 104, Visits: 734
That was it. I had deleted the mouth and eyes instead of importing them as well in the morph slider. Learning Reallusion products while switching back and forth from Blender to 3dsMax to iclone to 3dxchange to Crazytalk to CC to Blender to Photoshop to Premiere etc.....gets confusing.Whistling 
Edited
2 Years Ago by television_99
Snarp Farkle
Snarp Farkle
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (3.4K reputation)Distinguished Member (3.4K reputation)Distinguished Member (3.4K reputation)Distinguished Member (3.4K reputation)Distinguished Member (3.4K reputation)Distinguished Member (3.4K reputation)Distinguished Member (3.4K reputation)Distinguished Member (3.4K reputation)Distinguished Member (3.4K reputation)

Group: Forum Members
Last Active: Last Week
Posts: 719, Visits: 3.1K
Glad you figured it out television_99, I've had some odd results using OBJ's as well but it's usually something simple.


Dell XPS 8900, Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz, 3408 Mhz, 4 Core(s), 8 Logical Processor(s), 16 GB RAM, - 4 GB GeForce GTX 745, NVIDIA compatible.
Acer Aspire V Nitro Laptop,  2.5GHz Intel Core i5-7300HQ processor with 6MB cache,  256GB solid state drive, 16GB Ram,  4 GB NVIDIA GeForce GTX 1050 Ti graphics.

Kelleytoons
Kelleytoons
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)

Group: Forum Members
Last Active: 19 minutes ago
Posts: 5.9K, Visits: 11.9K
Okay, old thread (so hopefully someone is still paying attention, but in trying this it doesn't work for me, either.  And nothing I do with eyes or teeth seem to make a difference.

All I did was export the basic nude body into an OBJ, took the OBJ into Blender and just moved a few verts, and try importing back in as a morph and I get the same message.  So I then deleted the eyes and teeth in Blender with the same effect.  What am I missing?



Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
Rampa
Rampa
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)

Group: Forum Members
Last Active: 37 minutes ago
Posts: 6.9K, Visits: 36.8K
Plenty of room for error in the quad-to-tri conversion and all. You could try using the FBX mesh instead. It's already triangulated for CC.

Just guessing here:
Depending what modeler you're using, the OBJ verts could be all out of order, causing the triangles to be meshed improperly from the quads.
Edited
2 Years Ago by Rampa
but0fc0ursee
but0fc0ursee
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (1.5K reputation)Distinguished Member (1.5K reputation)Distinguished Member (1.5K reputation)Distinguished Member (1.5K reputation)Distinguished Member (1.5K reputation)Distinguished Member (1.5K reputation)Distinguished Member (1.5K reputation)Distinguished Member (1.5K reputation)Distinguished Member (1.5K reputation)

Group: Banned Members
Last Active: 2 Years Ago
Posts: 595, Visits: 1.7K
"Never" delete anything from the base mesh.
...that's asking for trouble.
Edited
2 Years Ago by but0fc0ursee
but0fc0ursee
but0fc0ursee
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (1.5K reputation)Distinguished Member (1.5K reputation)Distinguished Member (1.5K reputation)Distinguished Member (1.5K reputation)Distinguished Member (1.5K reputation)Distinguished Member (1.5K reputation)Distinguished Member (1.5K reputation)Distinguished Member (1.5K reputation)Distinguished Member (1.5K reputation)

Group: Banned Members
Last Active: 2 Years Ago
Posts: 595, Visits: 1.7K
Kelleytoons (10/16/2017)
Okay, old thread (so hopefully someone is still paying attention, but in trying this it doesn't work for me, either.  And nothing I do with eyes or teeth seem to make a difference.

All I did was export the basic nude body into an OBJ, took the OBJ into Blender and just moved a few verts, and try importing back in as a morph and I get the same message.  So I then deleted the eyes and teeth in Blender with the same effect.  What am I missing?

I do this and never have compatibility problems.

Head, eye, teeth, etc.
Export just as it is...
Then....

3rd party app.... 
~ Select the faces you want to work on and (Invert the Selection).
~ Then hit "Hide Selected."

Now edit it according to what's allowed. (keeping vertex count & order)
Then hit (Unhide All).

Your mesh is precisely the same as before (only vertex positions are changed).
________________________________________________

Morphing Logic:
The Morph modifier is only concerned with matching (count & order)...
then it simply moves vertex position to achieve the desired effect.
Hiding the verts.... is a sure fire way to make sure nothing is disturbed.
Poof!  Cool

Now if you have problems.... Check you settings.

Edited
2 Years Ago by but0fc0ursee
Kelleytoons
Kelleytoons
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)

Group: Forum Members
Last Active: 19 minutes ago
Posts: 5.9K, Visits: 11.9K
Well, I don't see how that will help given the only formats you can import for a morph are avatar and OBJ.

If you're saying I should export FBX from CC, bring it into Blender and export again as FBX and then bring into XChange and export as OBJ... that just seems to me not only a LOT of needless steps but also many, MANY places to slip (twixt the cup and the lip).  Shouldn't be nearly that complicated.



Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
Kelleytoons
Kelleytoons
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)

Group: Forum Members
Last Active: 19 minutes ago
Posts: 5.9K, Visits: 11.9K
Well, using FBX didn't work, Rampa, no matter what combination I tried.

Something is screwy here but I don't know what it is.



Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley



Reading This Topic