Profile Picture

[What's New] Releasing Unreal Live Link v1.22 for iClone (UE4.26 compatible!)

Posted By Eric C (RL) Last Year
Rated 5 stars based on 1 vote.

[What's New] Releasing Unreal Live Link v1.22 for iClone (UE4.26...

Author
Message
Eric C (RL)
Eric C (RL)
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)

Group: Administrators
Last Active: Yesterday
Posts: 429, Visits: 3.6K
Hi everyone,

We are pleased to announce that we are officially UE4.26 compatible now!
Come update your Unreal Live Link v1.22 and Auto Setup 1.11 plugin today, thanks!

You can also update these plugins via Reallusion Hub, thanks!

*Update your iClone Unreal Live Link Plugin @UE4Marketplace

Eric
oisilener1982
oisilener1982
Posted Last Year
View Quick Profile
Veteran Member

Veteran Member (844 reputation)Veteran Member (844 reputation)Veteran Member (844 reputation)Veteran Member (844 reputation)Veteran Member (844 reputation)Veteran Member (844 reputation)Veteran Member (844 reputation)Veteran Member (844 reputation)Veteran Member (844 reputation)

Group: Forum Members
Last Active: Last Month
Posts: 176, Visits: 1.3K
Thanks for this update
mmaclaurin
mmaclaurin
Posted Last Year
View Quick Profile
Junior Member

Junior Member (130 reputation)Junior Member (130 reputation)Junior Member (130 reputation)Junior Member (130 reputation)Junior Member (130 reputation)Junior Member (130 reputation)Junior Member (130 reputation)Junior Member (130 reputation)Junior Member (130 reputation)

Group: Forum Members
Last Active: Last Year
Posts: 4, Visits: 11
Working great! Is there any new functionality? And shouldn't you guys be taking a little break?
oisilener1982
oisilener1982
Posted Last Year
View Quick Profile
Veteran Member

Veteran Member (844 reputation)Veteran Member (844 reputation)Veteran Member (844 reputation)Veteran Member (844 reputation)Veteran Member (844 reputation)Veteran Member (844 reputation)Veteran Member (844 reputation)Veteran Member (844 reputation)Veteran Member (844 reputation)

Group: Forum Members
Last Active: Last Month
Posts: 176, Visits: 1.3K
Would it be possible to Transfer a Character from Unreal to iClone through live link in future updates? 

It is easy to send characters from iClone to Unreal but not the other way around.
Ghetzi
Ghetzi
Posted Last Year
View Quick Profile
Junior Member

Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)

Group: Forum Members
Last Active: 3 Months Ago
Posts: 14, Visits: 94
Glad to see this was updated to 4.26.  Unfortunately, I'm having problems compiling our project after enabling the auto-setup plugin.  Uninstalling the update resolves the problem, and a fresh install still results in a compile error.  I've got a support ticket in, but thought I'd comment here in case anyone else searching has an issue.  The update is only a day old, these things happen.  Will wait and update here once I find a solution!
Edited
Last Year by Ghetzi
Ghetzi
Ghetzi
Posted Last Year
View Quick Profile
Junior Member

Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)

Group: Forum Members
Last Active: 3 Months Ago
Posts: 14, Visits: 94
Ghetzi (12/29/2020)
Glad to see this was updated to 4.26.  Unfortunately, I'm having problems compiling our project after enabling the auto-setup plugin.  Uninstalling the update resolves the problem, and a fresh install still results in a compile error.  I've got a support ticket in, but thought I'd comment here in case anyone else searching has an issue.  The update is only a day old, these things happen.  Will wait and update here once I find a solution!


UPDATE:  Support's position on the matter is that the auto-setup plugin can only be installed in a new 4.26 project and will not work on an existing, already-in-progress 4.26 project.  Which seems off to me, but that's what they said so there must be a reason.  As a workaround, we're going to start a blank 4.26 project to work the characters, and then use the UE4 migrate tool to bring them into over to our main project which is already in mid-development.  Unless anyone else has any bright ideas?


lianchiu
lianchiu
Posted 9 Months Ago
View Quick Profile
Veteran Member

Veteran Member (645 reputation)Veteran Member (645 reputation)Veteran Member (645 reputation)Veteran Member (645 reputation)Veteran Member (645 reputation)Veteran Member (645 reputation)Veteran Member (645 reputation)Veteran Member (645 reputation)Veteran Member (645 reputation)

Group: Forum Members
Last Active: 3 Months Ago
Posts: 214, Visits: 1.5K
Ghetzi (12/29/2020)
Glad to see this was updated to 4.26.  Unfortunately, I'm having problems compiling our project after enabling the auto-setup plugin.  Uninstalling the update resolves the problem, and a fresh install still results in a compile error.  I've got a support ticket in, but thought I'd comment here in case anyone else searching has an issue.  The update is only a day old, these things happen.  Will wait and update here once I find a solution!



One question : Did you also copy CC_Shader from 4.25 into 4.26?
Ghetzi
Ghetzi
Posted 9 Months Ago
View Quick Profile
Junior Member

Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)

Group: Forum Members
Last Active: 3 Months Ago
Posts: 14, Visits: 94
lianchiu (1/4/2021)
Ghetzi (12/29/2020)
Glad to see this was updated to 4.26.  Unfortunately, I'm having problems compiling our project after enabling the auto-setup plugin.  Uninstalling the update resolves the problem, and a fresh install still results in a compile error.  I've got a support ticket in, but thought I'd comment here in case anyone else searching has an issue.  The update is only a day old, these things happen.  Will wait and update here once I find a solution!



One question : Did you also copy CC_Shader from 4.25 into 4.26?


Thanks for the reply and trying to help!  At the time of the project conversion from 4.25 to 4.26, we did not yet have CC3 and iClone7, so the autosetup was never installed to the project prior to converting.  We installed the updated plugin for 4.26 once I began using CC3 & IC7.  The iClone7 Live Link is working great, but not auto-setup.  For now, disabling the autosetup plugin in UE4 seems to be working fine.  We enable it to import from CC3 and run the setup (which works fine) and then disable it when we're done.  No compiling or packaging issues that way so far.  FWIW - support said the autosetup plugin will not work on projects converted from 4.25 to 4.26, and that it only works for projects started in 4.26.  Not sure why that is, but that's what they said.
Edited
9 Months Ago by Ghetzi
lianchiu
lianchiu
Posted 9 Months Ago
View Quick Profile
Veteran Member

Veteran Member (645 reputation)Veteran Member (645 reputation)Veteran Member (645 reputation)Veteran Member (645 reputation)Veteran Member (645 reputation)Veteran Member (645 reputation)Veteran Member (645 reputation)Veteran Member (645 reputation)Veteran Member (645 reputation)

Group: Forum Members
Last Active: 3 Months Ago
Posts: 214, Visits: 1.5K
i started a new project 4.25 (NO Auto setup and Live Link) there are some prop and Character in project 4.25 then I convert the project from 4.25 to 4.26.
After that I install the Auto setup for 4.26, and using Auto Setup to import FBX from CC and IC. no issue. 

so could you please record your workflow and show the error message.


I got this message is because i was using Auto setup for 4.25 but i opened it in 4.26
but in your case that you said you didn't use auto setup for 4.25 so i guess is different issue.

so please let us know what the workflow if you are not comfortable put in here you can PM me or submit to Feedback Tracker and leave the private comment
Ghetzi
Ghetzi
Posted 9 Months Ago
View Quick Profile
Junior Member

Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)Junior Member (215 reputation)

Group: Forum Members
Last Active: 3 Months Ago
Posts: 14, Visits: 94
lianchiu (1/6/2021)
i started a new project 4.25 (NO Auto setup and Live Link) there are some prop and Character in project 4.25 then I convert the project from 4.25 to 4.26.
After that I install the Auto setup for 4.26, and using Auto Setup to import FBX from CC and IC. no issue. 

so could you please record your workflow and show the error message.


I got this message is because i was using Auto setup for 4.25 but i opened it in 4.26
but in your case that you said you didn't use auto setup for 4.25 so i guess is different issue.

so please let us know what the workflow if you are not comfortable put in here you can PM me or submit to Feedback Tracker and leave the private comment

Thanks for being persistent in trying to help!  I didn't want to spam the forum, so I opened a new issue on the feedback tracker.  Our workaround of disabling the auto-setup plugin after using it is working fine, as the compile issue only happens when the plugin is enabled in the engine.  Also, the Live Link plugin is working fine and presents no compile issues, enabled or not.  So the issue is confined to auto-setup.  Thanks again!



Reading This Topic