Profile Picture

physics settings for long hair

Posted By johnwarndt52 Last Year
You don't have permission to rate!
Author
Message
johnwarndt52
johnwarndt52
Posted Last Year
View Quick Profile
Veteran Member

Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)

Group: Forum Members
Last Active: 4 Months Ago
Posts: 110, Visits: 227
Hello, I'm very confused and frustrated about how to handle unwanted motion in the hair of one of my characters and I'm hoping somebody here can help me figure it out.
Attached is a link to a very short screen grab video I made demonstrating the problem, with the physics settings for the hair at the right hand side of the screen. Also, I'll attach a still closeup of those settings.
As you can see, the girl on the left's long hair is being blown around as if in the wind, but that's not the effect I want to create. (I've already removed the first few seconds that always blow that sort of hair around, so that's not the issue.) Collision settings are only on for her head and neck so the hair doesn't seem to slice through her neck. (looking at her again, I realize I ought to turn that on for her chest, too.) The right hand arrow on the strength/range slider will not move any further to the left. If there's any way to tease it all the way to the left, I'd like to know.
Any help would be greatly appreciated.


https://forum.reallusion.com/uploads/images/1d24bb7c-cfbd-4e4e-ac0b-3531.jpg

Edited
Last Year by johnwarndt52
james_muia
james_muia
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 202, Visits: 1.1K
Hey johnwarndt52 - Try setting Inertia to 0 on the hair (ensure its the hair not the scalp) and see if that resolves the issue. I had a similar issue over the weekend.


IMDB: James Muia
Aviticus Dragon on YouTube


Computer Specs:
Intel® Core™ i7-7820X Processor (8x 4.30GHz/11MB L3 Cache)
Corsair Hydro Series H115i 280mm
Liquid CPU CoolerASUS ROG STRIX X299-E Gaming Motherboard
32 GB DDR4-3200 GSKILL Ripjaws V Memory
NVIDIA GeForce GTX 1080 Ti - 11GB - EVGA FTW3

johnwarndt52
johnwarndt52
Posted Last Year
View Quick Profile
Veteran Member

Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)

Group: Forum Members
Last Active: 4 Months Ago
Posts: 110, Visits: 227
James,
Sorry I took so long to get back to you on this.
I lowered the inertia to zero and that helped somewhat, but there was still some unwanted motion near the end of her hair, so I also turned the elasticity and stretch settings down to zero, and that helped some more, but seemed to lengthen her hair unrealistically. I'm bogged down on other aspects of this scene, but will get back to the hair when I get those worked ot
dante1st
dante1st
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)

Group: Forum Members
Last Active: Last Month
Posts: 454, Visits: 2.3K
I hope you can figure this out. For this very reason I've avoided this specific hair type - the long straight hair that covers the shoulders. Even the default hair physics templates aren't adequate for this, even when selecting this exact hair style for the setting.

--------------------------------------------------------------------------------------

My iClone short films: https://www.youtube.com/iClone316

james_muia
james_muia
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 202, Visits: 1.1K
No worries, hair physics can be challenging to nail down. Does her hair have proper weight maps? Usually they do but maybe check to make sure her hair has one.

The other thing to check would maybe be the wind settings and turning down the gusts perhaps.

Normally I dont mess with the elasticity settings as it seems to create weird results.

IMDB: James Muia
Aviticus Dragon on YouTube


Computer Specs:
Intel® Core™ i7-7820X Processor (8x 4.30GHz/11MB L3 Cache)
Corsair Hydro Series H115i 280mm
Liquid CPU CoolerASUS ROG STRIX X299-E Gaming Motherboard
32 GB DDR4-3200 GSKILL Ripjaws V Memory
NVIDIA GeForce GTX 1080 Ti - 11GB - EVGA FTW3

animagic
animagic
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (21.9K reputation)Distinguished Member (21.9K reputation)Distinguished Member (21.9K reputation)Distinguished Member (21.9K reputation)Distinguished Member (21.9K reputation)Distinguished Member (21.9K reputation)Distinguished Member (21.9K reputation)Distinguished Member (21.9K reputation)Distinguished Member (21.9K reputation)

Group: Forum Members
Last Active: 20 minutes ago
Posts: 12.3K, Visits: 21.5K
To tame the hair you can try reducing the contrast of the physics weight map. Keep the black black, but reduce the white to light gray. That is quite effective.


https://forum.reallusion.com/uploads/images/1a09220f-ab50-42ac-ad1a-33ec.pnghttps://forum.reallusion.com/Uploads/Images/d14339d0-cd32-4b35-88f9-40a0.png


dante1st
dante1st
Posted 5 Months Ago
View Quick Profile
Distinguished Member

Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)

Group: Forum Members
Last Active: Last Month
Posts: 454, Visits: 2.3K
james_muia (12/9/2019)
Hey johnwarndt52 - Try setting Inertia to 0 on the hair (ensure its the hair not the scalp) and see if that resolves the issue. I had a similar issue over the weekend.


I know this is old, but I just wanted to say, this right here might be the most underrated answer of all time given on this forum. That cannot be stressed enough.

For whatever genius reason, Reallusion has it where the DEFAULT material item is the SCALP, when you select hair, not the actual hair portion you'd be concerned with. So, if you're like me, and you selected hair, you could easily miss the fact that the hair physics you're tweaking is not for the hair, but for the scalp.

Only thing I'm not sure about, is why wasn't this an issue for me before? Meaning, I just now discovered the scalp thing I just mentioned....so shouldn't my character in all my previous videos have had hair collision issues before? Or was it only a recent update that mistakenly made the scalp be the default material item??? Then again she had short hair, so maybe it just wasn't noticeable.

Question: does scalp physics serve any purpose? I see that it is enabled by default. What's supposed to move there?




EDIT: nevermind. It doesn't matter which material you pick. It's one in the same. You make changes to one, and it does it for both.

--------------------------------------------------------------------------------------

My iClone short films: https://www.youtube.com/iClone316

Edited
5 Months Ago by dante1st
johnwarndt52
johnwarndt52
Posted 5 Months Ago
View Quick Profile
Veteran Member

Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)

Group: Forum Members
Last Active: 4 Months Ago
Posts: 110, Visits: 227
Animagic, sorry, but when I tweaked the contrast by turning down the white to light grey,  it just made a horrible mess out of her hair. And the slightest bit of movement on the slider bars cause her hair to fall off completely in the first few frames. It might be good for a comical effect, if that was what I was looking for.
Edited
5 Months Ago by johnwarndt52
johnwarndt52
johnwarndt52
Posted 5 Months Ago
View Quick Profile
Veteran Member

Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)Veteran Member (780 reputation)

Group: Forum Members
Last Active: 4 Months Ago
Posts: 110, Visits: 227
Dante, thanks but from the very beginning I made sure I was choosing the hair, not the scalp. I think the best I can do right now is to keep the inertia down to zero, like james_muima  recommended. But I don't understand why the little green arrowhead on the slider for the "Strength (Range)" settings (right above Gust Frequency at the very bottom of the panel ) won't go all the way to Zero. My scene is indoors and I don't need or want any wind of any sort.
dante1st
dante1st
Posted 5 Months Ago
View Quick Profile
Distinguished Member

Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)

Group: Forum Members
Last Active: Last Month
Posts: 454, Visits: 2.3K
Nevermind what I said, it looks like it doesn't matter which "material" you pick, the changes are made for both, and is not treated differently.

As for you wind question, I believe that's normal. That strength slider only controls the different strengths of wind if you have gust turned on. It's set at zero, so that strength slider doesn't affect it (since all it does is tell the program the different strengths of wind to blow, when it does blow).

--------------------------------------------------------------------------------------

My iClone short films: https://www.youtube.com/iClone316




Reading This Topic