Profile Picture

Sketch-up 6 to 3DXchange4 Pro Help

Posted By brothertcoleman 9 Years Ago
You don't have permission to rate!
Author
Message
brothertcoleman
brothertcoleman
Posted 9 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)

Group: Forum Members
Last Active: 3 days ago
Posts: 476, Visits: 4.5K
Most of the  (.skp) files I downloaded as Sketch-up 6  still come into 3dxchange4 as blocky and missing colors.They are fine when I view them in  Sketch-up,do I need a plug-in or am I doing something wrong ?

Thanks just starting in the Iclone Universe.

| Windows 7 | iClone 4 Pro | 3DXchange 4 Pro | CrazyTalk 6 Pro |FaceFilter Studio2 |

DAZ Studio 3 |Blender

 

| Windows 10 64bit / iClone6 Pro /CrazyTalk 8 Pipline /FaceFilter v3 PRO/ CrazyTalk Animator 3 Pipeline/Serif DrawPlus X8 / 3DXchange 6 Pro /WidgetCast PRO/DP Animation Maker /PopVideo 3

Edited
9 Years Ago by brothertcoleman
Galfridus
Galfridus
Posted 9 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (2.0K reputation)Distinguished Member (2.0K reputation)Distinguished Member (2.0K reputation)Distinguished Member (2.0K reputation)Distinguished Member (2.0K reputation)Distinguished Member (2.0K reputation)Distinguished Member (2.0K reputation)Distinguished Member (2.0K reputation)Distinguished Member (2.0K reputation)

Group: Forum Members
Last Active: Last Month
Posts: 654, Visits: 2.1K
Hello brothertcoleman, Welcome to the forum.

There`s an auto smooth function to help deal with the "blockiness". Type auto smooth into help for instructions or watch this tutorial vid. http://www.youtube.com/watch?v=3cqETcSGyr8

I have also experienced that some sketch up models have multiple textures which don't seem to auto import into 3DX4. I don't know why this is so. My fix for this is that I usually save each texture as a jpeg via the Materials window in Sketch Up. I then import each file individually back to the appropriate section of the model in 3DX4. Clicking the model areas with the dropper tool helps identify which texture file is required for each part.

This works for me most of the time but it can be a bit time consuming. I'd be glad to hear if any of the experts on the forum has a speedier solution for when the textures don't auto import.

Good luck

Geoff.

https://forum.reallusion.com/uploads/images/ba17ca1f-2bbe-4b61-819c-6bdf.png


brothertcoleman
brothertcoleman
Posted 9 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)

Group: Forum Members
Last Active: 3 days ago
Posts: 476, Visits: 4.5K
Galfridus thanks for the information,I know its not just me . 

| Windows 10 64bit / iClone6 Pro /CrazyTalk 8 Pipline /FaceFilter v3 PRO/ CrazyTalk Animator 3 Pipeline/Serif DrawPlus X8 / 3DXchange 6 Pro /WidgetCast PRO/DP Animation Maker /PopVideo 3
brothertcoleman
brothertcoleman
Posted 9 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)

Group: Forum Members
Last Active: 3 days ago
Posts: 476, Visits: 4.5K

Forgive me if there is a manual for this question.

I know you can change and add color to items imported from google sketch-up 6 but my problem is some parts cant be seperated to recolor them individually because some of the body parts were created together even when I dont select them in the scene tree of 3DXchange4.(see picture please).

Is there any free program or any kind of paint tool that I can add individual color to whats missing?

I can't paint eyes,mustach sideburns without painting all the parts.

Is there a simple paint tool or something in 3DXchange4 or  iClone v4.3 PRO after I send prop there? 

Thanks

***One last questions is it against the rules here to post for someone to make a list of Nintendo ,Sega etc  Characters and I offer to pay?


| Windows 10 64bit / iClone6 Pro /CrazyTalk 8 Pipline /FaceFilter v3 PRO/ CrazyTalk Animator 3 Pipeline/Serif DrawPlus X8 / 3DXchange 6 Pro /WidgetCast PRO/DP Animation Maker /PopVideo 3

Edited
9 Years Ago by brothertcoleman
rontarrant
rontarrant
Posted 9 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)

Group: Forum Members
Last Active: 4 Years Ago
Posts: 231, Visits: 571
I found the model of Luigi you're working with, downloaded it, and I've come up with a solution that should get you most of the way. You'll need to do a bit of editing on this model in SketchUp before it'll give you the results you want.

The problem is around the eyes. What the model-maker did was add an extra mesh around each eye to mask the edges of the eyeballs. If you remove these, the eyes will show through in 3DXchange.

Some of the polygons in these meshes are hidden or something (I don't know SketchUp well enough to figure this part out) so you may have to come up with a trick or two of your own to get rid of them.

But, to get the texturing back in 3DXchange, here's what you can do:
- open the model in SketchUp
- get rid of the extra "masking" meshes around the eyes (just select, then delete; undo if you grab the wrong ones)
- recolor his mustache (for whatever reason, this is the only way to avoid him ending up with white facial hair)
- open the Windows -> Materials dialog
- click on the Select tab (if it's not already the active tab)
- look for the house icon, click it (this gives you a display of all the materials used in the model)
- right-click on each of the swatches and, for the ones that have the option in the context menu, select Export Texture Image (use the default names even though they're cryptic; you'll be matching these filenames later in 3DXchange)
- you can save these textures in whatever file format you want, but for this process I'm assuming you'll use jpg.

Now load the model into 3DXchange and scroll (or jump) the Modify panel down to the Materials section.

In the model hierarchy (on the left) start at the top and click on the first sub-mesh. Over on the right, in Modify/Materials, you'll see a filename in the Selected Material box. This will correspond with one of the textures you just saved from SketchUp, but the extension will be .tga instead of the .jpg you saved. What you need to do is retexture each mesh with the .jpg version.

To do this, click on the Diffuse icon and look for the Open button further down. (Note: you aren't doing a Load Material, you're adding a texture map).

Navigate to the folder where you saved all the .jpg textures from SketchUp and find the one that has the same name (minus the extension, of course) and apply it.

Do this for every mesh that shows a filename in the Selected Materials box.

Now go to the Modify panel's Normal section. Select each mesh in turn and click Auto Smooth. The default 45 degrees should be fine for most things, but for the hands, you'll want to crank it up to 90.

Hope this helps.

- Ron T.

brothertcoleman
brothertcoleman
Posted 9 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)

Group: Forum Members
Last Active: 3 days ago
Posts: 476, Visits: 4.5K
Thanks, I will print what you wrote and try it at work tonight.

| Windows 10 64bit / iClone6 Pro /CrazyTalk 8 Pipline /FaceFilter v3 PRO/ CrazyTalk Animator 3 Pipeline/Serif DrawPlus X8 / 3DXchange 6 Pro /WidgetCast PRO/DP Animation Maker /PopVideo 3
brothertcoleman
brothertcoleman
Posted 9 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)Distinguished Member (5.0K reputation)

Group: Forum Members
Last Active: 3 days ago
Posts: 476, Visits: 4.5K
WOW!!!

I followed your suggestions  step for step and it worked great.Thank You

I did Mario first instead but they are the same.I was able to get all the parts to work in iclone 4 Pro just I can't use the torso and legs (can't separate to use).I just used Jimmy Toon and put the body parts on him to test before I try them with Clone bone.

Thanks very much exited to work on it more later.

 

| Windows 10 64bit / iClone6 Pro /CrazyTalk 8 Pipline /FaceFilter v3 PRO/ CrazyTalk Animator 3 Pipeline/Serif DrawPlus X8 / 3DXchange 6 Pro /WidgetCast PRO/DP Animation Maker /PopVideo 3

rontarrant
rontarrant
Posted 9 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)

Group: Forum Members
Last Active: 4 Years Ago
Posts: 231, Visits: 571
brothertcoleman (10/29/2010)
WOW!!!

I followed your suggestions step for step and it worked great.Thank You


I'm glad I could help, brothercoleman. Smile Happy animating!

- Ron T.




Reading This Topic