Profile Picture

Not getting any GPU acceleration

Posted By mistergrav Last Year
You don't have permission to rate!
Author
Message
mistergrav
mistergrav
Posted Last Year
View Quick Profile
New Member

New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)

Group: Forum Members
Last Active: Last Year
Posts: 3, Visits: 24
Hi there!  I'm a new user to CTA5, and hopefully I'm missing something obvious...

I'm getting very low framerates, but my system is good, with an i7 11th gen Intel processor and RTX3060 gpu.
When I check the NVIDIA GPU Activity, I see that Affinity designer is utilizing the GPU, but CTA is not.
Is there a setting I need to adjust to get GPU acceleration from Cartoon Animator 5?

Thanks so much!

mistergrav
mistergrav
Posted Last Year
View Quick Profile
New Member

New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)

Group: Forum Members
Last Active: Last Year
Posts: 3, Visits: 24
Okay, I got it working and the framerates more than quadrupled!

Here's what I did:
1) update graphics drivers (always do this first, of course)
2) Open Nvidia Control Panel, then in "Manage 3D Settings", there is a dropdown for "Preferred Graphics Processor".  I changed that from "Auto-Select" to "High performance NVIDIA processor"
3) From that screen, there's also a link to "Windows Graphics Settings".  From here, click "Default Graphics Settings", then turn on "Hardware Accelerated GPU Scheduling"

It seems that both windows and nvidia were assuming that CTA5 was not going to need GPU support, so my laptop was limiting its access to the GPU, which is a good feature when it gets it right, but CTA5 definitely needs the boost.

I don't see a way to change these settings specifically for CTA5, which would be ideal, since now I turned off power saving features that could be beneficial while running other apps.  Is this a bug?  Is there a way for Reallusion to tell Windows that it requests GPU support on machines with power-saving settings turned on?  I'm not versed in that side of programming, so I don't know.  But if Affinity Designer got access, what did they do differently?

Anyway, hopefully this helps someone else who is getting poor framerates on a laptop!
Peter (RL)
This post has been flagged as an answer
Peter (RL)
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (114.6K reputation)Distinguished Member (114.6K reputation)Distinguished Member (114.6K reputation)Distinguished Member (114.6K reputation)Distinguished Member (114.6K reputation)Distinguished Member (114.6K reputation)Distinguished Member (114.6K reputation)Distinguished Member (114.6K reputation)Distinguished Member (114.6K reputation)

Group: Administrators
Last Active: 5 hours ago
Posts: 22.5K, Visits: 35.4K
Thanks for letting us know that were able to resolve the problem. Your advice will certainly help others in the same situation.

Unfortunately with laptops that have switchable graphics you can encounter these problems when the Nvidia GPU is not automatically selected. For example. on some computers the high performance GPU will automatically be disabled if you run on battery power which will obviously cause performance issues.

One thing to be careful of is if you change the global setting to always use the high performance GPU, then you will notice poor battery life even when using software that doesn't really need the Nvidia GPU. It is normally better to setup a separate program profile in the Nvidia Control Panel for Cartoon Animator and leave the global setting at the default "Auto".


                                                                

Peter
Forum Administrator

www.reallusion.com


mistergrav
mistergrav
Posted Last Year
View Quick Profile
New Member

New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)New Member (50 reputation)

Group: Forum Members
Last Active: Last Year
Posts: 3, Visits: 24
Thanks for the reply, Peter!

At your suggestion, I looked harder for the way to specify how to set GPU-acceleration for just CTA5 and not globally.  I did not find the option in the NVIDIA Control Panel, but I did in the Windows Graphics Settings!  Cartoon Animator was not in the list auto-generated by Windows, so I thought I was out of luck, but I looked too quickly the first time.  Underneath "Custom options for Apps", you can "Add an App."  Browse for CTA5 (on my system, it is here: "C:\Program Files\Reallusion\Cartoon Animator 5\bin64\CartoonAnimator.exe") and now it will appear on the list of apps, allowing you to choose "High Performance".

I then set my default setting back to turn off Hardware Accelerated GPU Scheduling, restarted my computer, and everything works great.  The GPU Activity shows CTA5 and my framerates are still good, without sacrificing the power-saving features!

Thanks again!



Reading This Topic