Profile Picture

Turn off collision shape or import custom collision shape for rigid body

Posted By spaehling 4 Months Ago
You don't have permission to rate!

Turn off collision shape or import custom collision shape for rigid...

Author
Message
spaehling
Idea.png
spaehling
Posted 4 Months Ago
View Quick Profile
Senior Member

Senior Member (316 reputation)Senior Member (316 reputation)Senior Member (316 reputation)Senior Member (316 reputation)Senior Member (316 reputation)Senior Member (316 reputation)Senior Member (316 reputation)Senior Member (316 reputation)Senior Member (316 reputation)

Group: Forum Members
Last Active: 2 Weeks Ago
Posts: 14, Visits: 209
hey guys,
i tried to create some earrings and i mostly get everything to work with constrains, but the head collision has a conflict with the earrings. earrings start to freak out, if they are to close to the head.
of course i would love to keep head collision for hair, but i can dispense the collison for the earring self, so if they moves into head, would be fine for me.

has some one an idea? i allready posted an entry into feedback tracker, but maybe some of you has an idea i maybe oversaw. When i turn off head collision, everything works fine, but of 
course hair goes through head too. so my solution would be, keep constrains and turn off collision for the earring, but keeps physics enabled.

greets Spaehling


animagic
animagic
Posted 4 Months Ago
View Quick Profile
Distinguished Member

Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)Distinguished Member (21.8K reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 12.3K, Visits: 21.5K
You can do this in two phases by baking the Soft Cloth Physics for the hair. Make sure to have some extra frames at the beginning of your project for the physics to settle.

In the first phase, proceed as follows:

1. You disable the Rigid Body Physics for the earrings and enable the collision shape for the head.
2. You also enable Soft Cloth Physics for the hair and make sure that  Bake Animation is checked for Soft Cloth (in Project settings).
3. Now set your playback speed to By Frame and press play. You will now "record" the Soft Cloth animation for the hair. Once done, disable Soft Cloth Physics for the hair. 

The hair animation is now done.

In the second phase, proceed as follows:

1. You disable the collision shape for the head and enable the Rigid Body Physics for the earrings.
2. Now "record" the physics for the earrings. Once done, you can disable the physics for the earrings.

Finally, set the playback speed back to "Realtime"and watch the result.

Obviously, you would need to make sure that all other animation in the scene has already been completed.


https://forum.reallusion.com/uploads/images/1a09220f-ab50-42ac-ad1a-33ec.pnghttps://forum.reallusion.com/Uploads/Images/d14339d0-cd32-4b35-88f9-40a0.png


spaehling
spaehling
Posted 4 Months Ago
View Quick Profile
Senior Member

Senior Member (316 reputation)Senior Member (316 reputation)Senior Member (316 reputation)Senior Member (316 reputation)Senior Member (316 reputation)Senior Member (316 reputation)Senior Member (316 reputation)Senior Member (316 reputation)Senior Member (316 reputation)

Group: Forum Members
Last Active: 2 Weeks Ago
Posts: 14, Visits: 209
hey, thanks for your quick reply. had no chance to answer until now.
i had some similiar solution in mind with kinematic mode and recording like you explained, but i did not tried it out yet and i hoped i could avoid that. cause like you said, the animations needs to be done at this point.
so maybe reallusion add the options to just turn off the collision on the physics asset Smile but great that you explained it well. i will definlity try it out.



Reading This Topic