Profile Picture

Skin or clothing is poking through after export

Posted By jurien Last Year
You don't have permission to rate!
Author
Message
jurien
jurien
Posted Last Year
View Quick Profile
Senior Member

Senior Member (362 reputation)Senior Member (362 reputation)Senior Member (362 reputation)Senior Member (362 reputation)Senior Member (362 reputation)Senior Member (362 reputation)Senior Member (362 reputation)Senior Member (362 reputation)Senior Member (362 reputation)

Group: Forum Members
Last Active: 52 minutes ago
Posts: 21, Visits: 390
Hi, 

I exported the standard CC3 character Hivewire_Huntress without any changes except the hair.
Then imported in Unreal and found that some poking of clothing and skin occured. This was not visible in CC3 before exporting. 
See attached images.

And because I exported with the "single material", the option for " delete hidden mesh"  was greyed out.
See attached images 

Can I fix this issue in CC3 Before exporting?

https://forum.reallusion.com/uploads/images/5b9a4604-0350-49da-8bc2-5281.jpg
https://forum.reallusion.com/uploads/images/6c9d6536-b14f-4bff-b33d-4735.jpghttps://forum.reallusion.com/uploads/images/107a3b4d-314a-4b24-b90a-2312.jpg
danielswright2311_182877
danielswright2311_182877
Posted Last Year
View Quick Profile
Senior Member

Senior Member (386 reputation)Senior Member (386 reputation)Senior Member (386 reputation)Senior Member (386 reputation)Senior Member (386 reputation)Senior Member (386 reputation)Senior Member (386 reputation)Senior Member (386 reputation)Senior Member (386 reputation)

Group: Forum Members
Last Active: 3 Months Ago
Posts: 88, Visits: 320
You have to adust skin weights and reservice the mesh to the bones before export, you could also load in your exported mesh into 3ds max or blender to also re-skin your meshes. 




Check out my new Bible Forums
jurien
jurien
Posted Last Year
View Quick Profile
Senior Member

Senior Member (362 reputation)Senior Member (362 reputation)Senior Member (362 reputation)Senior Member (362 reputation)Senior Member (362 reputation)Senior Member (362 reputation)Senior Member (362 reputation)Senior Member (362 reputation)Senior Member (362 reputation)

Group: Forum Members
Last Active: 52 minutes ago
Posts: 21, Visits: 390
@danielswright2311_182877 Thank you for the reply.

But how can I adjust the skin weights properly in CC3 when nothing is poking and all seems to be looking fine, even with different poses selected.
The suggestion to re-skin it in another 3D application is something I want to avoid, because I bought CC3 for this task.
And second, the poking is not happening when I can export with the "delete hidden mesh" option, but then it exports with multiple materials and that is not what I want to achieve.

I suppose exporting it twice with single material and another export with delete hidden mesh enabled is an option, but I think the uvs get messed up this way? 
Can someone clarify this? Or show me a workaround so I can get the desired mesh + single material export.
Edited
Last Year by jurien
Peter (RL)
Peter (RL)
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (52.0K reputation)Distinguished Member (52.0K reputation)Distinguished Member (52.0K reputation)Distinguished Member (52.0K reputation)Distinguished Member (52.0K reputation)Distinguished Member (52.0K reputation)Distinguished Member (52.0K reputation)Distinguished Member (52.0K reputation)Distinguished Member (52.0K reputation)

Group: Administrators
Last Active: 8 hours ago
Posts: 15.9K, Visits: 24.1K
Hi... 

Here are a couple of things to try in CC3. These will normally resolve the problem for you.

Method One : 
Select the clothing item showing poke thru.
Then go to Edit Mesh > Face  > Visible :  Show All (to display the hidden mesh)
Now use Pull or Push the vertex to correct the problem. 

Method Two : 
Select the clothing item showing poke thru.
Then go to Edit Mesh > Face  > Visible :  Show All
Now go to Conform > Outfit Settings > Loose fitting :  Set 1 or a little higher. 
Calculate Collision.

And we will allow "Delete Hidden Mesh" to work with Merge Material in a future patch. Smile


                                                                

Peter
Forum Administrator

www.reallusion.com


modernstoryteller
modernstoryteller
Posted 5 Months Ago
View Quick Profile
Distinguished Member

Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)Distinguished Member (1.1K reputation)

Group: Forum Members
Last Active: Last Month
Posts: 67, Visits: 281
I found another workaround for this issue:
Assuming your skin material has an opacity map, you can export the opacity map, select the areas of the skin map you never want to see in-game, and make them all black. Then re-import the skin map into the engine. That way, the skin peeping through the clothing mesh is invisible.
It's rough and dirty, but it works.



Reading This Topic