Profile Picture

Why does character turn dark in Final Render

Posted By rfbindl Last Year
You don't have permission to rate!
Author
Message
rfbindl
rfbindl
Posted Last Year
View Quick Profile
Senior Member

Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)

Group: Forum Members
Last Active: Last Month
Posts: 15, Visits: 276
I'm having trouble with the Final Render creating extremely dark shadows or turning off lights on a certain camera angle or character position. The only way I've been able to resolve is turn ambient color off in PBR Setup, but then another character gets flooded with light from same angle as shadow on 1st character.

Lighting is good in Preview Render. I've also tried High, Medium, and Quick mode, but still get dark shadow. Below is a copy of video's rendered.
https://forum.reallusion.com/uploads/images/0ec7d7c1-0957-4b21-b6ce-c4bd.jpg

Terry Miller
Terry Miller
Posted Last Year
View Quick Profile
Veteran Member

Veteran Member (571 reputation)Veteran Member (571 reputation)Veteran Member (571 reputation)Veteran Member (571 reputation)Veteran Member (571 reputation)Veteran Member (571 reputation)Veteran Member (571 reputation)Veteran Member (571 reputation)Veteran Member (571 reputation)

Group: Forum Members
Last Active: 5 hours ago
Posts: 44, Visits: 838
If you have already checked this, forgive me, but just a few weeks ago, I had something similar happen. Turns out that I had forgotten that my Auxiliary Light was on (it only shows up in Preview), and when I rendered, what I got was awful! Turning off Aux Light and making sure my regular lights were on solved it quickly. Good luck!https://forum.reallusion.com/uploads/images/cea58f89-a809-4836-9c51-9aa3.jpg


rfbindl
rfbindl
Posted Last Year
View Quick Profile
Senior Member

Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)

Group: Forum Members
Last Active: Last Month
Posts: 15, Visits: 276
Thanks Terry. I had checked the Aux light. Wish it was that, but it wasn't. Only thing that's come close to working is playing with PBR, but then I still get saturation of light on another character. I can get some out by adjusting 3 light sources, but not all. The preview copy looks best.  
Keith_MPS
Keith_MPS
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)Distinguished Member (1.2K reputation)

Group: Forum Members
Last Active: Last Week
Posts: 372, Visits: 1.2K
Go into Edit -> Preferences and look at the Real-Time Render Options as well as the Advanced options. It's described here in the manual:
http://manual.reallusion.com/iClone_7/ENU/Pro/Default.htm#iClone_7/Pro_7.0/04_Introducing_the_User_Interface/Real_Time_Render_Options.htm

If all of the boxes are checked, but the preview still does not look like the render, then I'm not sure.  If checking boxes causes the preview to look like the render then you can figure out what effect is causing the darkness.


- Keith
Edited
Last Year by Keith_MPS
rfbindl
rfbindl
Posted Last Year
View Quick Profile
Senior Member

Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)Senior Member (398 reputation)

Group: Forum Members
Last Active: Last Month
Posts: 15, Visits: 276
Keith_MPS (8/21/2018)
Go into Edit -> Preferences and look at the Real-Time Render Options as well as the Advanced options. It's described here in the manual:
http://manual.reallusion.com/iClone_7/ENU/Pro/Default.htm#iClone_7/Pro_7.0/04_Introducing_the_User_Interface/Real_Time_Render_Options.htm


Thanks Keith; I tried those also... used High, Med, Quick mode to change boxes form none to a few to all, but same results. Also checked/unchecked some that I thought might impact it.

I'm not totally sure but it seems that PBR is the issue. I unchecked "Convert All Shaders to PBR" in the Project PBR setup and that worked on the most obvious section. A few shadows were more subdued in short (200 frames) final render test, but it may work okay. I'm rending full project now, but that will take an hour or so. I'm still not sure this was the best fix, but it does get rid of really dark shadow.



Reading This Topic