Profile Picture

Morph Animator: ATTACH vs LINKAGE

Posted By Lord Ashes 2 Years Ago
You don't have permission to rate!
Author
Message
Lord Ashes
Lord Ashes
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)

Group: Forum Members
Last Active: Last Month
Posts: 1.2K, Visits: 1.4K
I am not sure if this is a "bug" or "functions as designed":

I have a prop which has a morph added via Morph Creator. When I add the prop to a project, I can use Morph Animator to apply and remove the morph...as expected.

When I use the LINKAGE function, in iClone, to link the prop to a character, the prop and morph continue to work fine. However, using the LINKAGE option, when I edit the iClone character in CC, the prop is not included and thus I am unable to take it into CC in order to turn it into a CC accessory.

When I use the ATTACH function, in iClone, to attach the prop to a character, the morph stops working. Morph Animator still shows the slider for the morph but changing the slider value does not apply the morph anymore. 

Is this an intentional limitation because CC does not support props/accessories with morphs? Or is this a bug?


"We often compare ourselves to the U.S. and often they come out the best, but they only have the right to walk on the grass while we have the right to smoke it"
Lord Ashes' Original
4u2ges
4u2ges
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)Distinguished Member (5.3K reputation)

Group: Forum Members
Last Active: 35 minutes ago
Posts: 1.7K, Visits: 7.0K
What a funny coincident. Just a while ago I was thinking about creating a small tut about attaching props which have animated morphs. Then I figure it would not be that quick and small and gave up on it.
But the key point is: to have attached props retain their morphs, do simply REAPPLY the morphs to the attached prop from the Morph Creator and everything falls in place.

Here I have a morphed rolling window. The current sub-props hierarchy is  CAR > BODY > PASS DOOR >  WINDOW
I did morph window while it was detached. After attaching it to the Door, the morph has stopped working, so I simply hit "Update Morph to iClone" and window morph is alive once more.

(no materials applied here yet)

https://forum.reallusion.com/uploads/images/cf18697e-8d98-4e23-b894-7221.jpg




Edited
2 Years Ago by 4u2ges
Lord Ashes
Lord Ashes
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)

Group: Forum Members
Last Active: Last Month
Posts: 1.2K, Visits: 1.4K
It took me a moment to follow your instructions because when I clicked my ATTACHed prop, it no longer offered Morph Creator (only Morph Animator). The solution seemed to be to select the character (not the prop) which gives the option for Morph Creator. This then has the "Update Morph to iClone" button that you spoke of.

Once I figured that out, your solution worked like a charm.

Note: Once this solution is used, the Morph works from both the character or the prop itself.

"We often compare ourselves to the U.S. and often they come out the best, but they only have the right to walk on the grass while we have the right to smoke it"
Lord Ashes' Original
CtrlZ
CtrlZ
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (2.6K reputation)Distinguished Member (2.6K reputation)Distinguished Member (2.6K reputation)Distinguished Member (2.6K reputation)Distinguished Member (2.6K reputation)Distinguished Member (2.6K reputation)Distinguished Member (2.6K reputation)Distinguished Member (2.6K reputation)Distinguished Member (2.6K reputation)

Group: Forum Members
Last Active: 12 hours ago
Posts: 288, Visits: 3.2K
@Lord Ashes&@4u2ges Good question great answerCool Thank you both!!




Home built liquid cooled AMD Ryzen 7 1800X cpu (8 core 16 thread) 4.0GHz,  2x GTX 1080 ti (11gb) SLI, ASUS Crosshair VI Hero motherboard, 64 GB RAM, 500 GB SSD (Samsung 850 EVO) 6 TB HD's 4K monitor.
                                                                                                                                  



Reading This Topic