Profile Picture

Content Uploader requesting external file ....?

Posted By h_habash 2 Years Ago
You don't have permission to rate!
Author
Message
h_habash
h_habash
Posted 2 Years Ago
View Quick Profile
Veteran Member

Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)

Group: Forum Members
Last Active: Last Year
Posts: 30, Visits: 494
I've made this Clock and applied Physics Toolbox - Motor D to apply animation to the pendulums, I want to upload it but the content uploader show this message:

"One or more items may require external files: Please check your AML setting and make sure no external file is required. If users who download these items without external files, these items can not work properly. Do you want to continue?"

I have tried to find out a solution myself for a couple of days, but give up now..!.

Can anyone give me a hint on how to overcome this! BigGrin




__________________________________________________________________________________________________________________________________________
"Committed to Excellence"
__________________________________________________________________________________________________________________________________________
DELL Inspiron, Intel Core(R) I7-3517U CPU @ 1.9GHz 1.9GHz, 8GB RAM, 1TB SSHD, NVIDIA GeForce GT 630M.

_________________________________________________________________________________________________________________________________________

Rampa
Rampa
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)

Group: Forum Members
Last Active: 1 minute ago
Posts: 6.9K, Visits: 36.8K
I would not use the physics pack. It uses Bullet physics which cannot run at the same time as PhysX, which is what almost all iClone projects use.

You can just use a physics hinge constraint. If the pendulum has no damping on it, it will rock back-and-forth forever.

Click on the constraint button and the panel will open. Drag the Hinge constraint onto the upper end of your pendulum. Rotate your pendulum a little (my picture is at 45, but it only needs a little bit). Make sure the pendulum has no damping. Hit play and watch it swing.

To attach the constraint (and thus the pendulum) to your clock, set your clock to a static or kinematic physics, and select the hinge on the pendulum and set it's parent to be the clock in the modify panel. 

https://forum.reallusion.com/uploads/images/5e314d59-772d-490f-aa79-3939.jpg

https://forum.reallusion.com/uploads/images/b8519244-7362-47e6-9f88-6b1a.jpg
h_habash
h_habash
Posted 2 Years Ago
View Quick Profile
Veteran Member

Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)

Group: Forum Members
Last Active: Last Year
Posts: 30, Visits: 494
Thanks Rampa, this is a great help, I'm going to try this now.


__________________________________________________________________________________________________________________________________________
"Committed to Excellence"
__________________________________________________________________________________________________________________________________________
DELL Inspiron, Intel Core(R) I7-3517U CPU @ 1.9GHz 1.9GHz, 8GB RAM, 1TB SSHD, NVIDIA GeForce GT 630M.

_________________________________________________________________________________________________________________________________________

Snarp Farkle
Snarp Farkle
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (3.4K reputation)Distinguished Member (3.4K reputation)Distinguished Member (3.4K reputation)Distinguished Member (3.4K reputation)Distinguished Member (3.4K reputation)Distinguished Member (3.4K reputation)Distinguished Member (3.4K reputation)Distinguished Member (3.4K reputation)Distinguished Member (3.4K reputation)

Group: Forum Members
Last Active: Last Week
Posts: 719, Visits: 3.1K
Great info Rampa, I learned something new again, thanks!


Dell XPS 8900, Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz, 3408 Mhz, 4 Core(s), 8 Logical Processor(s), 16 GB RAM, - 4 GB GeForce GTX 745, NVIDIA compatible.
Acer Aspire V Nitro Laptop,  2.5GHz Intel Core i5-7300HQ processor with 6MB cache,  256GB solid state drive, 16GB Ram,  4 GB NVIDIA GeForce GTX 1050 Ti graphics.

h_habash
h_habash
Posted 2 Years Ago
View Quick Profile
Veteran Member

Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)

Group: Forum Members
Last Active: Last Year
Posts: 30, Visits: 494
Finally, I've completed the steps rampa suggested, thanks rampa for your wonderful and get to point suggestion I really appreciate it, it works great and I will follow these steps in the future props.

But, unfortunately the Content Uploader still giving the same message I've mentioned earlier, except it's not mentioning the AML settings "This because I removed the performance from the prop" !!


__________________________________________________________________________________________________________________________________________
"Committed to Excellence"
__________________________________________________________________________________________________________________________________________
DELL Inspiron, Intel Core(R) I7-3517U CPU @ 1.9GHz 1.9GHz, 8GB RAM, 1TB SSHD, NVIDIA GeForce GT 630M.

_________________________________________________________________________________________________________________________________________

Edited
2 Years Ago by h_habash
h_habash
h_habash
Posted 2 Years Ago
View Quick Profile
Veteran Member

Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)

Group: Forum Members
Last Active: Last Year
Posts: 30, Visits: 494
Ok, I've made something here, I took everything to 3Dexchange and re-export it to IClone, and wow... the uploader accept it finally without any issue.

Again, Thanks Rampa for your helpful input on this....


__________________________________________________________________________________________________________________________________________
"Committed to Excellence"
__________________________________________________________________________________________________________________________________________
DELL Inspiron, Intel Core(R) I7-3517U CPU @ 1.9GHz 1.9GHz, 8GB RAM, 1TB SSHD, NVIDIA GeForce GT 630M.

_________________________________________________________________________________________________________________________________________

Rampa
Rampa
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)Distinguished Member (24.4K reputation)

Group: Forum Members
Last Active: 1 minute ago
Posts: 6.9K, Visits: 36.8K
Glad to hear it worked! You can also bake the physics and collect the clip if you want it to be a perform action.

Show us a movie of it when you're ready.
h_habash
h_habash
Posted 2 Years Ago
View Quick Profile
Veteran Member

Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)Veteran Member (525 reputation)

Group: Forum Members
Last Active: Last Year
Posts: 30, Visits: 494
Here is a starter version of the known kids song I'm working on (Heckory Deckory Dock).



I'm still working on enhancement.


__________________________________________________________________________________________________________________________________________
"Committed to Excellence"
__________________________________________________________________________________________________________________________________________
DELL Inspiron, Intel Core(R) I7-3517U CPU @ 1.9GHz 1.9GHz, 8GB RAM, 1TB SSHD, NVIDIA GeForce GT 630M.

_________________________________________________________________________________________________________________________________________

Lord Ashes
Lord Ashes
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)Distinguished Member (11.0K reputation)

Group: Forum Members
Last Active: Last Month
Posts: 1.2K, Visits: 1.4K
h_habash (4/8/2017)
I've made this Clock and applied Physics Toolbox - Motor D to apply animation to the pendulums, I want to upload it but the content uploader show this message:
"One or more items may require external files: Please check your AML setting and make sure no external file is required. If users who download these items without external files, these items can not work properly. Do you want to continue?"
I have tried to find out a solution myself for a couple of days, but give up now..!.
Can anyone give me a hint on how to overcome this! BigGrin

I've wondered about this message myself...I am not sure if it isn't something left over from some old code. I have received this warning a number of times when uploading different content and, in each case, I just click OK (or whatever the option is to continue) and never had any problems with my content in the marketplace (or I have a lot of customers which are overtly nice and have not complained ;-))




"We often compare ourselves to the U.S. and often they come out the best, but they only have the right to walk on the grass while we have the right to smoke it"
Lord Ashes' Original



Reading This Topic