Kinect Setup???


https://forum.reallusion.com/Topic373436.aspx
Print Topic | Close Window

By sonic7 - 2 Years Ago

Hi makeurmark ....
It shouldn't take that long - but then again it shouldn't 'stall' either....
When I did my installation, (the first time), it was ONLY the 'Kinect for Xbox One' that I used.
I've heard that installing other mocap software *can* cause problems, which is why they should be removed first.
Between the time I installed the *trial*, and the time I eventually went with the paid version, I *did* download and install some microsoft programs relating to the Kinect v2, but again, I made certain they were un-installed first, before loading Reallusion's mocap software.
I didn't do anything *special* - just the usual windows 10 "app removal" ...
I'm sure sorry you're having this trouble .... it's frustrating when this sort of thing occurs.
I'm no computer Guru, but *maybe* someone here who is can help with this. It does seem strange that it hangs - have you tried just forcing a re-boot to see if it picks up where it left off ?

Sorry - overlapping posts - plus I was distracted ......

By makeurmark - 2 Years Ago
I keep getting "User Account Control"  window every time I launch the plugin, asking do you want to allow this app from an unknown publisher to make changes to your device?
Normally I get this once and thereafter it doesn't appear.
I think applying Administer privileges to the plugin launcher made it work, bit now displays the above window

By makeurmark - 2 Years Ago
Is there a setting inside iClone that determined which Graphics card it uses?
Does the information below prove that the G Card has DirectX 12 installed? Is this the latest version?

https://forum.reallusion.com/uploads/images/62af6066-fea3-4037-98d2-835b.png
By makeurmark - 2 Years Ago
Finally today I was forced to restore my MSI to factory default. That was a feat in it self.
But at least I got the spinning GeForce logo under NVidia Control panel.
I am currently re-installing iClone. Then I will install Motion Live Plugin, followed by Kinect Mocap Plugin for Xbox One.

Cross fingers...

PS. Thanks so much for all your patience and support during my frustration.
By makeurmark - 2 Years Ago
Doesn't look like the plugin installed correctly.
I'm wondering whether the blank window that opens is meant to have some content.
https://forum.reallusion.com/uploads/images/b7e312c5-140b-40c3-add6-13be.png
By sonic7 - 2 Years Ago
Hi makeurmark ...
I'm sorry, I don't understand what you mean by the window is 'see through'....
But, the 'Kinect lighting up' is certainly a good sign - and if you either 'minimize' or move the *plugin's window* 'out of the way'... then go into the 'animation tab' and choose "Device Mocap" (if you haven't already), and you'll see a "Device Console" panel appear. Then you click on "Connect". Next, you select "Preview" (at the bottom), and your Avatar *should* burst into life, and start following your movements ... Smile
By Rampa - 2 Years Ago
I had not asked if your machine had dual graphics yet. You pick the card to use in the Explorer. Check this video. It covers both Nvidia and AMD.


So you would want to make sure that RL apps are on the 1070.

Often you can choose just right-clicking on the app's icon.
By sonic7 - 2 Years Ago

Hope all goes well for you Mark!
By makeurmark - 2 Years Ago
Thanks guys

I used Uninstall Programmes under Control panel to delete any Kinect installations, downloaded the plugin (Kinect for Xbox One) from my account on Reallusion and hit run.
The installation is still hanging at 50% after 15 minutes. How long did the installs take you?
Kinect for Xbox One was the first installer I tried on Friday, which seems stop at 50%.

Thanks again
By sonic7 - 2 Years Ago

Good thought .... yes - let's *hope* that works ......
By makeurmark - 2 Years Ago
Kinect Plugin not displayed under "Device Manager", see screenshot.
Graphics Card listed on screen shot.

Thanks Guys

https://forum.reallusion.com/uploads/images/86e4f9c1-8444-4dd0-ae98-57db.png
By Kelleytoons - 2 Years Ago
makeurmark (7/17/2018)

I'm beginning to wonder that because my laptop is a gaming laptop, whether because it's been optimised for gaming I'm struggling with 3D software


That shouldn't be an issue -- my own MSI is, obviously, a gaming laptop and it runs Kinect and iClone just fine (to be fair, I have never run RL's Kinect plugin on it, but I do run iPisoft's and there's no problem at all).

First issue is to get the nVidia driver thing straightened out -- and MSI should be able to help with that.

By Peter (RL) - 2 Years Ago
If you have the "Kinect For Xbox One" then you should only install the plug-in for that version. Installing multiple versions of the plug-in can cause problems.

I would advise installing the plug-in with the Kinect disconnected and iClone closed down. Once the plug-in is installed, then connect the hardware and installation should be finalised. You can also try right clicking on the plug-in installer and choose "Run As Administrator".
By sonic7 - 2 Years Ago

I'd be tempted to force a re-boot .....
By sonic7 - 2 Years Ago

makeurmark ....
If you go to your PC's "Device Manager" - are you able to see "Kinect sensor devices" listed there? ......

https://forum.reallusion.com/uploads/images/2365d43b-7f34-4fcc-80ab-0c61.png

I'd say it would *HAVE TO BE* otherwise you wouldn't be able to select *Connect* ......

*** It *seems* as though something isn't *in place* to give you your "preview" ....
Could it be Direct X or something similar that's not "loaded" or "up to date?"

Seems to me it's a display software problem .....

GPU Driver ? Up to date?

Possibly make sure your graphics drivers up to date and re-boot .....
And - do you have the 'latest version' of the mocap plugin?
By makeurmark - 2 Years Ago
Third day and the frustration gets worse.
Thank you so much for the help I am receiving on this chat.

Sonic7 - followed your last instructions but it made no difference, even though you were correct about changing manual to automatic, which I did.

I have even re-installed the Graphics card drivers through GForce Experience app.

I'm still getting "Not responding" from the NVidia Control panel after right clicking on desktop and selecting from there.
I've attached a screenshot of the NVidia Control Panel, which clearly says not responding on top left. I have also noticed that the preview screen never shows a preview.

I have been in touch with MSI them selves to see if this can be resolved and will update as I go along.
I'm beginning to wonder that because my laptop is a gaming laptop, whether because it's been optimised for gaming I'm struggling with 3D software.

Thanks again for all your support.
Markhttps://forum.reallusion.com/uploads/images/80f7ebb4-9bb6-44e8-adb1-d69d.png
By makeurmark - 2 Years Ago
I'm trying to setup an xbox one Kinect to iClone.
The hardware is all connected along with the adapter for PC.
I'm having a problem with the plugin. I just purchased the Kinect Mocap plugin from Reallusion. However the purchase includes two downloads:
Mocap Plug-in Kinect XboxOne
Mocap Plug-in Kinect Win, Mocap Plug-in Kinect Xbox360

I have tried running both downloads but at around 50% install the whole thing hangs.
I left the process to run for 30 minutes, but the progress bar didn't move.
I have tried searching for a solution but frustratingly the only setup guide include the plugin all ready installed.

Do I need to download the Windows version?

By makeurmark - 2 Years Ago
The screenshot shows the blank "Kinect for Windows Runtime Setup" window. If I close this window the install continues.
Should there be content inside this window? Where I need to hit OK or Agree?
https://forum.reallusion.com/uploads/images/c1b030f3-cac3-40ed-9056-e82e.png

By sonic7 - 2 Years Ago

Yeah .... I feel your 'frustration' for sure ....
Well....
● I don't understand why you've had #1■ transparency and #2■ white --- in your Mocap Plugin window. (I've not experienced this at all).
● I'm slightly 'surprised' that you can "connect" in your "Device Console" - when the Plugin Window isn't behaving properly. - I wouldn't thought that possible.
● The "User Account Control" message you get (still get?) - is also a mystery - again - new to me ...
I'll do some research .....
By sonic7 - 2 Years Ago

Try 'rebooting' first.
If that doesn't help, you could *try* this:

Go to your start menu, type in msconfig, open it up. Click on the services tab, sort by name, find the nvidia services. See if "NVIDIA NetworkService Container is running. It may be checked, but see if it's running.
If not, go to your control panel, administrative tools, then services. Find that service in there. It's probably set to manual and isn't running. Set it to automatic, and start it. Reboot.

source: 
https://www.reddit.com/r/pcmasterrace/comments/6937jg/nvidia_control_panel_crashes_when_launched/

If that doesn't work, you could perhaps try this:
https://www.drivereasy.com/knowledge/nvidia-control-panel-wont-open-fixed/

By makeurmark - 2 Years Ago
I just returned to the install and noticed an extra Kinect installer window that was open. It was blank so I got fed up and closed the window.

The installation immediately continued and finished. So I'll get the Kinext plugged in and see if it all works.
By makeurmark - 2 Years Ago
Eventually got the plugin to open, but now have another issue:
The Kinect plugin window opens and connects to the Kinect, however the window is see through.  have attached a screenshot. The Kinect lights up when connected.
You can see the plugin window surrounding the Avatar.https://forum.reallusion.com/uploads/images/761920c6-32cf-4f36-a912-013d.png
By sonic7 - 2 Years Ago

Well these are the 'required' specs:

KINECT Mocap Plug-in – Xbox One:

  • 64-bit ( x64 ) processor - Physical dual-core 3.1 GHz ( 2 logical cores per physical ) or faster processor

  • USB 3.0 controller dedicated to the Kinect for Windows v2 sensor or the Kinect Adapter for Windows ( $49.99 ) for use with the Kinect for Xbox One ( $149.99 ) sensor

  • 4 GB of RAM

  • Graphics card that supports DirectX 11

  • Windows 8 or 8.1, Windows Embedded 8, or Windows 10 ( x64 )

  • iClone Pro v 6.21 and above

So, assuming your graphics card has the 'DirectX 11' installed, I would have thought you'd be good to go ....
By sonic7 - 2 Years Ago

Mark .... - I'm surprised that 'right clicking' the desktop *doesn't* bring up your Graphics Panel.
When this happened with me (though in my case it was for the AMD Radeon Panel), I found that 'reinstalling' the Graphics Drivers and Rebooting - fixed it - and the right click began working again, ie: the 'cause' was the Graphics Drivers not being up to date ......
By sonic7 - 2 Years Ago
Try 'rebooting'
Also try running as 'Administrator' ....
By makeurmark - 2 Years Ago
Hi sonic7
What I meant about see through was that the plug-in window is transparent. You can see the frame surrounding the avatar, but you can see the avatar through the panel.
I have tried the process you explain. But I just followed the process again.
I have attached another screen shot:
"Device Console" is connected, however Preview is greyed out. "Kinect Mocap Plug-in - Xbox One v1.0" is connected, but the plug-in window is white?
You mentioned frustration in an earlier post. Tell me about it...https://forum.reallusion.com/uploads/images/cdbe2854-206c-4401-8c9b-bd0d.png
By makeurmark - 2 Years Ago
That's strange.
When I open NVidia Control Pannel it crashes. When I open Task Manager NVidia Control Panel "is not responding".

My MSI laptop is like 6 months old. Not used extensively. I'll need to dig a little more.

I'll get back to you later. Off for a little fresh air now.


Thanks for staying with me on this. It is much appreciated.
Mark
By Snarp Farkle - 2 Years Ago
Hey makeurmark,

You might get some insightful input from [THIS THREAD], there's a few interesting ideas on how to set up the Kinect.
By makeurmark - 2 Years Ago
Thanks for your patients sonic7.
I have tried rebooting on several occasions.
I am going to try a reboot and install from downloaded file rather then running the download.
Cross fingers.
By Peter (RL) - 2 Years Ago
makeurmark (7/16/2018)
Hi sonic7
What I meant about see through was that the plug-in window is transparent. You can see the frame surrounding the avatar, but you can see the avatar through the panel.
I have tried the process you explain. But I just followed the process again.
I have attached another screen shot:
"Device Console" is connected, however Preview is greyed out. "Kinect Mocap Plug-in - Xbox One v1.0" is connected, but the plug-in window is white?
You mentioned frustration in an earlier post. Tell me about it...https://forum.reallusion.com/uploads/images/cdbe2854-206c-4401-8c9b-bd0d.png


White or transparent windows normally indicates graphics driver issues or an incompatible graphic card is being used. Which graphic card are you using?
By sonic7 - 2 Years Ago

Mark ... as far as I'm aware, you shouldn't have any problem using a 'gaming laptop' with iClone and the Kinect .....
But to be totally honest - I'm no PC expert, so I'm 'struggling' with this as much as you ...
There *are* other 'fixes' on the internet for 'nvidia control panel won't open/crashes' etc. - I'd be trying to exhaust those avenues ...
From *some* of the bits I read, there was the odd account where this type of problem occured after installing certain drivers....
Steve.
Edit: ..... Did you try 'Rampa's suggestion' of *Right Clicking* on the 'app's icon' to see if you can change it to work on the 1070 graphics?