Converting iClone 7 projects to iClone 8 - Motion Layer has no keyframes


https://forum.reallusion.com/Topic544592.aspx
Print Topic | Close Window

By waveforms - Last Year
Is this typical behavior? I'm opening old projects I made in 7, and while they come in cleanly, there are no keyframes in the motion layer.
I can sample the motion layer, but of course this is inferior to having the original interpolated keyframes.

Any help here is appreciated.
By animagic - Last Year
waveforms (12/2/2023)
Is this typical behavior? I'm opening old projects I made in 7, and while they come in cleanly, there are no keyframes in the motion layer.
I can sample the motion layer, but of course this is inferior to having the original interpolated keyframes.

Any help here is appreciated.

To be able to be useable in iClone 8 the motion tracks need to be converted and that means that the keyframes are "absorbed". I believe that the reason for this conversion is that the animation system has been overhauled and is not directly compatible.

For iClone 7 projects to be used in iClone 8, I make sure that they are pretty much in their final state before conversion. I still need to make adjustments sometimes because a character's location may shift.
By waveforms - Last Year
Thank you kindly for this reply and for relaying your workarounds on the issue.

the animation system has been overhauled and is not directly compatible

Is this documented somewhere? I'm curious to read about it.
In my opinion, this is a serious drawback and borderline dishonest of Reallusion to market IC8 as having backwards compatibility with IC7. 

Especially when IC8's core animation remains quite similar to that of 7.
If there was an overhaul on the keyframe system, the resulting improvements are not obvious to me, and I would welcome being corrected on this.