Transfer skin weights "fails" @ a triangle "threshold"


https://forum.reallusion.com/Topic494993.aspx
Print Topic | Close Window

By sonic7 - Last Year

Been having repeatedly predictable CC3 "crashes" while attempting to *transfer skin weights* (using CC3's 'default' weighting template).
Turns out, it's most likely to do with the >number of triangles<. Here's what I observed:

With an Avatar (a Cyborg) plus accessories, (totalling 1.31 million tris), I attempted to perform 'skin weighting' on a group of merged accessories that totalled 113 thousand tris. It would 'start' the mesh processing, but then, after a few seconds, would *crash* (every time). After trying different things, I decided to temporarily delete around 300k of mesh that wasn't needed immediately during the skin weighting process.
So with the project now sitting at just on 1 million tris, I tried the weighting again - and this time - *SUCCESS!*

This may be simply 'system related' (I run a modest setup - nothing 'beefy'), but I thought it worth mentioning in case anyone else experiences crashes durung CC3 weighting. Hope it helps someone Smile