Composer/External Image Editor Photoshop Bug???
Print Topic | Close Window

By ms12 - 8 Years Ago
Attached is an animated gif showing an attempt at editing a G3 character using an external editor. I have seen this done in a few youtube videos, however when I try and edit 2 files are created in photoshop when only one should be created. Saving to either file does not affect the character in G3  Is this a bug or am I doing something wrong?

Using Mac 10.12.1
By garylearntech - 8 Years Ago
Curious - it's the alpha channel (the mask) that you're seeing in the second image.  I've just repeated this with Affinity Photo, and also with several of the other stock G3 characters.  (I'm currently using CTA3.02.)

You'll find there are two images opened in your image editor.  #1 is the alpha channel data and that window is titled foo_Opacity.png.  That's the one that primarily black and white.  #2 is the main image window and is named foo_Diffuse.png.  Unlike your experience, I found that editing foo_Diffuse.png and saving it (a simple cmd-S) saved the changes straight back to CTA3.

Some of the characters are "cleaner" than others.  Try Elastic Folks Female and look at the split images in Photoshop/Affinity Designer/etc for a nice clean example.  Then once you can relate the mask image, take another look at your Ted character and see how the mask is doing more work to produce the final image.  At the furthest extreme, take a look at the Caveman components - in this example, it's the mask doing almost all the work to produce the final image.

I know that with time that has passed since you posted your original enquiry that you have possibly sussed this and moved on.  But with new users coming on board, I thought it might be worthwhile 'documenting' this for their benefit.

By garylearntech - 7 Years Ago
Ahh - it's a bug.  I found the online manual documents the settings under Preferences > System Section.  Twirl open the final "Texture Launch Settings" and you'll see the two PNG options described.  To make this work the way you expect (at least for now), go into CTA's Preferences and, in the Texture box, choose "PNG" instead of the default "PNG with Alpha".

I've logged it in the Feedback Tracker.