Profile Picture

Animated Hair Textures in Unreal

Posted By Blazoneer Last Month
You don't have permission to rate!
Author
Message
Blazoneer
Blazoneer
Posted Last Month
View Quick Profile
Senior Member

Senior Member (382 reputation)Senior Member (382 reputation)Senior Member (382 reputation)Senior Member (382 reputation)Senior Member (382 reputation)Senior Member (382 reputation)Senior Member (382 reputation)Senior Member (382 reputation)Senior Member (382 reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 18, Visits: 73
When I import a character from CC3 to Unreal, the hair textures display as expected. However, when I assign that very same CC3 skeleton an animated asset from iclone, the hair textures vanish, and the hair looks like the underlying modeling material.   

When I import the animation from iClone, I do the following

- do not import skeleton
- do not import mesh
- do not import textures
- do not import materials

The hair texture is assigned properly & automatically via CC3 Auto Setup.  Basically, when exporting animations from iClone, all that should be imported into Unreal is the underlying animation information.  Within Unreal, since the hair shows properly on the CC3 skeleton, the hair should also display properly during animation.  Nothing is really changing.  Yet, the hair acts as if it's some type of new mesh.

-----------------

Solved: if I retarget the animations to a new skeleton, the shaders update with that skeleton's shaders. Not retargeting the animation uses shaders from another skeleton, which may or may not match, creating potential problems.
Edited
Last Month by Blazoneer



Reading This Topic