Profile Picture

Daz Materials not Importing via Transformer

Posted By Jayso Last Year
You don't have permission to rate!
Author
Message
Jayso
Jayso
Posted Last Year
View Quick Profile
Senior Member

Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 36, Visits: 231
Hi all, 
My imported Daz Genesis 8 character seems to be missing some important textures from Daz. I imported via the transformer in CC3 and all looks well, except for the missing textures. Could it be that these missing textures were only part of Daz MAT files and not compatible with CC3?https://forum.reallusion.com/uploads/images/5ef8218b-d371-4040-9849-3070.jpg
Edited
Last Year by corganb
Kelleytoons
Kelleytoons
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)

Group: Forum Members
Last Active: 17 minutes ago
Posts: 7.7K, Visits: 16.8K
Make sure after you select the "Advanced" button (which you should ALWAYS select) you also checkmark "Bake Body Texture" at whatever resolution you want.

If that doesn't work please provide a link to the Daz page where this object/character is sold and  I'll be glad to check it out.






Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
Jayso
Jayso
Posted Last Year
View Quick Profile
Senior Member

Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 36, Visits: 231
Hi Kelleytoons, 

I've used the advanced "bake textures" method as well, without luck. Normal maps and other roughness-like textures don't seem to be importing. The Genesis 8 character is https://www.daz3d.com/snowman-hd-for-genesis-8-male

Thank you for your time and all that you do for the forum!
Edited
Last Year by Jayso
Kelleytoons
Kelleytoons
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)

Group: Forum Members
Last Active: 17 minutes ago
Posts: 7.7K, Visits: 16.8K
But after choosing "Advanced" you also then checkmarked "Bake Body Textures" and selected, say, 4024?

You need to do this to get the skin textures to come over.  Note that even thought it's "HD" those details will NOT come over (CC3 does not support Daz HD details).  I'll check this figure out later but this is a busy day for me (my surgical post-op and PT so I may not get to checking this out until tomorrow).



Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
Jayso
Jayso
Posted Last Year
View Quick Profile
Senior Member

Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 36, Visits: 231
confirmed that bake body textures and full res were selected.
Edited
Last Year by Jayso
Kelleytoons
Kelleytoons
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)

Group: Forum Members
Last Active: 17 minutes ago
Posts: 7.7K, Visits: 16.8K
Okay, after a (long) day of PT and surgeon stuff, we celebrated my progress and had a late night of alcohol.  So, sorry, didn't get a chance to look at this until this morning.

Things like this all come down to naming conventions -- because FBX files don't include anything other than the diffuse textures, we've had to use some (I think) clever ways of trying to find the remaining channels.  The first place to start is to take the diffuse name and then try and match it up with other materials in the folder.

In this case, the diffuse is called "BigRough_Base_Color", which is a problem right way because all the other channels use only the prefix "BigRough" to identify themselves.  Thus the normal map is "BigRough_Normal" which would be easy to find IF it were "BigRough_Base_Color_Normal".

What I did in my routines is strip out underscores, and then look for things like "BC" or "Base" or "BaseColor" (case is always ignored) and strip that out as well,  And it appears that RL's own code (based on mine) does this and works fine.

So -- I get all these textures working fine for me.  I can go through the progress, but it should be as simple as you check marking bake textures.  You might want to check your texture folder (in Daz it's Runtime/Textures/JoeQuick/Snowman) and make sure they are there and named properly.  Otherwise this character works fine for me.

https://forum.reallusion.com/uploads/images/84dd2f64-a3e4-4eca-9ee9-b2cb.png






Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
Jayso
Jayso
Posted Last Year
View Quick Profile
Senior Member

Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)Senior Member (389 reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 36, Visits: 231
Thanks for your reply and congrats on the progress. 

So, do I need to rename the Daz provided textures to match the transformer's expected naming convention? I've located the source folder and see the PBR textures. From a tutorial video of yours, I thought that simply dragging the textures into the missing spaces in CC3 wasn't the proper way to do this. When I try to add the "BigRough" textures this way, the wrap seems wrong. 

Kelleytoons
Kelleytoons
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)

Group: Forum Members
Last Active: 17 minutes ago
Posts: 7.7K, Visits: 16.8K
I didn't do anything and the textures came in just fine.  I'll make a video showing the whole process so you can follow along and perhaps you need to reinstall CC3 (because it should work correctly for you).  I'll try and get the video up this afternoon.



Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
Kelleytoons
Kelleytoons
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)

Group: Forum Members
Last Active: 17 minutes ago
Posts: 7.7K, Visits: 16.8K




Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
Kelleytoons
Kelleytoons
Posted Last Year
View Quick Profile
Distinguished Member

Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)Distinguished Member (26.3K reputation)

Group: Forum Members
Last Active: 17 minutes ago
Posts: 7.7K, Visits: 16.8K
If yours does not work, then your Export Options in Daz for FBX are incorrect (make sure you don't have anything checkmarked in Output Options other than Merge Clothing, allow degraded skinning and scaling, and SubD information -- and use FBX 2012 binary).



Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley



Reading This Topic