Profile Picture

Character Sliding When Walking

Posted By adamanton 3 Months Ago
You don't have permission to rate!
Author
Message
adamanton
adamanton
Posted 3 Months Ago
View Quick Profile
Senior Member

Senior Member (338 reputation)Senior Member (338 reputation)Senior Member (338 reputation)Senior Member (338 reputation)Senior Member (338 reputation)Senior Member (338 reputation)Senior Member (338 reputation)Senior Member (338 reputation)Senior Member (338 reputation)

Group: Forum Members
Last Active: 8 days ago
Posts: 10, Visits: 89
I have my custom characters walking from the background to the foreground along the Z-Axis. I'm using the animations in the Content Manager Walk (1S), Walk (2L), etc. and enlarging them as they get to the foreground. The problem is the walking does not look natural and they are sliding back as they walk, almost as if like they're on one of those airport people-movers going the wrong way. Anyone know how to fix his? Thank you.
Peter (RL)
Peter (RL)
Posted 3 Months Ago
View Quick Profile
Distinguished Member

Distinguished Member (61.9K reputation)Distinguished Member (61.9K reputation)Distinguished Member (61.9K reputation)Distinguished Member (61.9K reputation)Distinguished Member (61.9K reputation)Distinguished Member (61.9K reputation)Distinguished Member (61.9K reputation)Distinguished Member (61.9K reputation)Distinguished Member (61.9K reputation)

Group: Administrators
Last Active: 3 hours ago
Posts: 17.5K, Visits: 26.6K
Hi...

If you are looping two (or more) walk forward motion clips and the character jumps back when the second clip starts, just do the following.

1. On the Timeline select the second walk forward motion clip. 
2. Then on the Menu Bar select Animation > Motion Align > Root.

The walk animation should then continue seamlessly.


                                                                

Peter
Forum Administrator

www.reallusion.com


adamanton
adamanton
Posted 2 Months Ago
View Quick Profile
Senior Member

Senior Member (338 reputation)Senior Member (338 reputation)Senior Member (338 reputation)Senior Member (338 reputation)Senior Member (338 reputation)Senior Member (338 reputation)Senior Member (338 reputation)Senior Member (338 reputation)Senior Member (338 reputation)

Group: Forum Members
Last Active: 8 days ago
Posts: 10, Visits: 89
Thanks for responding. The walk is pretty seamless from the movement of legs/feet, etc. The problem is the whole character seems to be sliding backwards as I move him forward. It's like he's slip-sliding.

Peter (RL)
Peter (RL)
Posted 2 Months Ago
View Quick Profile
Distinguished Member

Distinguished Member (61.9K reputation)Distinguished Member (61.9K reputation)Distinguished Member (61.9K reputation)Distinguished Member (61.9K reputation)Distinguished Member (61.9K reputation)Distinguished Member (61.9K reputation)Distinguished Member (61.9K reputation)Distinguished Member (61.9K reputation)Distinguished Member (61.9K reputation)

Group: Administrators
Last Active: 3 hours ago
Posts: 17.5K, Visits: 26.6K
Can you post a short video or some screenshots which show the issue. This will help us understand the problem a little better.

                                                                

Peter
Forum Administrator

www.reallusion.com


kylelee
kylelee
Posted 2 Months Ago
View Quick Profile
Distinguished Member

Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)Distinguished Member (1.3K reputation)

Group: Forum Members
Last Active: 2 days ago
Posts: 354, Visits: 3.3K
You can try to switch the camera mode to Orthographic in Project Settings.

https://forum.reallusion.com/uploads/images/b0ce6b5a-3286-4a73-9970-d995.png



Reading This Topic