Profile Picture

Hair rendering problem

Posted By charly Rama 3 Years Ago
You don't have permission to rate!
Author
Message
charly Rama
charly Rama
Posted 3 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)

Group: Forum Members
Last Active: 23 minutes ago
Posts: 1.6K, Visits: 13.6K
Hello guys,

I have a big problem, hairs seem good in preview as here
https://forum.reallusion.com/uploads/images/4115d42d-16be-4582-9b0f-8a2a.png

But in rendering, there are some transparent squares as here

https://forum.reallusion.com/uploads/images/d5175e12-1171-483c-9e2b-b49e.png
Where does it come from ? thank you for your help


     


animagic
animagic
Posted 3 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (29.7K reputation)Distinguished Member (29.7K reputation)Distinguished Member (29.7K reputation)Distinguished Member (29.7K reputation)Distinguished Member (29.7K reputation)Distinguished Member (29.7K reputation)Distinguished Member (29.7K reputation)Distinguished Member (29.7K reputation)Distinguished Member (29.7K reputation)

Group: Forum Members
Last Active: 14 hours ago
Posts: 14.9K, Visits: 26.9K
I have seen hair artifacts when the hair is in front of an object with some transparency. However, looking at your scene that doesn't seem to be the case. Things like smoke also can give problems.

That said, all these issues have supposedly been resolved.


https://forum.reallusion.com/uploads/images/436b0ffd-1242-44d6-a876-d631.jpg

justaviking
justaviking
Posted 3 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (19.6K reputation)Distinguished Member (19.6K reputation)Distinguished Member (19.6K reputation)Distinguished Member (19.6K reputation)Distinguished Member (19.6K reputation)Distinguished Member (19.6K reputation)Distinguished Member (19.6K reputation)Distinguished Member (19.6K reputation)Distinguished Member (19.6K reputation)

Group: Forum Members
Last Active: Last Week
Posts: 8.2K, Visits: 26.5K
Awww... that kid is SO SAD...  Sad

Excellent work on him.

As Animagic said, I too have seen iClone's renderer struggle when overlapping items both have transparency.  I hope you get it figured out because your scene looks great.




iClone 7... Character Creator... Substance Designer/Painter... Blender... Audacity...
Desktop (homebuilt) - Windows 10, Ryzen 9 3900x CPU, GTX 1080 GPU (8GB), 32GB RAM, Asus X570 Pro motherboard, 2TB SSD, terabytes of disk space, dual  monitors.
Laptop - Windows 10, MSI GS63VR STEALTH-252, 16GB RAM, GTX 1060 (6GB), 256GB SSD and 1TB HDD

Edited
3 Years Ago by justaviking
TonyDPrime
TonyDPrime
Posted 3 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (11.5K reputation)Distinguished Member (11.5K reputation)Distinguished Member (11.5K reputation)Distinguished Member (11.5K reputation)Distinguished Member (11.5K reputation)Distinguished Member (11.5K reputation)Distinguished Member (11.5K reputation)Distinguished Member (11.5K reputation)Distinguished Member (11.5K reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 3.4K, Visits: 12.1K
I can't think of a good reason why iClone is producing render errors which are not showing in viewport.
This may be a specific issue with the character, or maybe, just maybe, a bug.
Whenever I encountered transparency issues they always appear in BOTH viewport and render.

Charly - are you using Super Sampling of any type?  Assuming you are using Final Render, what happens if you instead run the render as Preview?
TonyDPrime
TonyDPrime
Posted 3 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (11.5K reputation)Distinguished Member (11.5K reputation)Distinguished Member (11.5K reputation)Distinguished Member (11.5K reputation)Distinguished Member (11.5K reputation)Distinguished Member (11.5K reputation)Distinguished Member (11.5K reputation)Distinguished Member (11.5K reputation)Distinguished Member (11.5K reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 3.4K, Visits: 12.1K
I can't think of a good reason why iClone is producing render errors which are not showing in viewport.
This may be a specific issue with the character, or maybe, just maybe, a bug.
Whenever I encountered transparency issues they always appear in BOTH viewport and render.

Charly - are you using Super Sampling of any type?  Assuming you are using Final Render, what happens if you instead run the render as Preview?
4u2ges
4u2ges
Posted 3 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (17.2K reputation)Distinguished Member (17.2K reputation)Distinguished Member (17.2K reputation)Distinguished Member (17.2K reputation)Distinguished Member (17.2K reputation)Distinguished Member (17.2K reputation)Distinguished Member (17.2K reputation)Distinguished Member (17.2K reputation)Distinguished Member (17.2K reputation)

Group: Forum Members
Last Active: 2 hours ago
Posts: 4.4K, Visits: 14.8K
Can you post screenshot of the exact render settings for that second image?




4u2ges
4u2ges
Posted 3 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (17.2K reputation)Distinguished Member (17.2K reputation)Distinguished Member (17.2K reputation)Distinguished Member (17.2K reputation)Distinguished Member (17.2K reputation)Distinguished Member (17.2K reputation)Distinguished Member (17.2K reputation)Distinguished Member (17.2K reputation)Distinguished Member (17.2K reputation)

Group: Forum Members
Last Active: 2 hours ago
Posts: 4.4K, Visits: 14.8K
I just made this video to show the reasons for this ugly bug.

Any time you render a close shots of the hair, or any other object with dense opacity maps, you get ugliness when:

1. You render with full screen, or fairly large view-port.
2. You enable Super Sampling

Question: How to overcome those artifacts without disabling SS?
Answer: Render with SMALL view-port. The size of the view-port should be determined experimentally.

Here is an example:

My screen resolution is 2560x1440px and I am rendering 1920x1080px video
Demo video contains three, 3 seconds repeated clips.



Clip1 - Render with "Optimize with Full Screen Render" and SS 3x3 enabled. Result - is horrible hair opacity artifacts.
Clip2 - Render with "Optimize with Full Screen Render" checked , but no SS. Result is better, but artifacts are still there.
Clip3 - Render with SMALL view-port and SS 3x3 enabled. Result - all artifacts are gone.

Here is how view-port looked like when I fired up Export for clip 3:
https://forum.reallusion.com/uploads/images/d6fa213c-8173-48c0-b32f-a29f.jpg

Full screen / large view-port size renders have certain advantages such as smoothing jagged edges on some objects with enabled glow, suppressing GI flickering.. etc. And it is faster.
But when it comes to close head shots with certain hair, it is just unacceptable.
I usually render close shots separately from the rest of the video for that reason.





Edited
3 Years Ago by 4u2ges
Dr. Nemesis
Dr. Nemesis
Posted 3 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (2.7K reputation)Distinguished Member (2.7K reputation)Distinguished Member (2.7K reputation)Distinguished Member (2.7K reputation)Distinguished Member (2.7K reputation)Distinguished Member (2.7K reputation)Distinguished Member (2.7K reputation)Distinguished Member (2.7K reputation)Distinguished Member (2.7K reputation)

Group: Forum Members
Last Active: Last Month
Posts: 258, Visits: 5.4K
Charly try making your viewport as small as you can and then render.
It’ll take considerably longer but in my experience it fixes that problem.

Just try a couple frames first so you don’t waste a ton of time if it doesn’t work.

Edit: 4u2ges beat me by 7 seconds.
Edited
3 Years Ago by Dr. Nemesis
charly Rama
charly Rama
Posted 3 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)

Group: Forum Members
Last Active: 23 minutes ago
Posts: 1.6K, Visits: 13.6K
Thank you guys for your help..

I've disabled SS, reduced viewport, but it's still so ugly Smile maybe  I just won't shoot a close-up view, which would be a shame because it is to show the sadness

https://forum.reallusion.com/uploads/images/bf743e6c-9c1f-445a-a410-b0fc.png



     


charly Rama
charly Rama
Posted 3 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)Distinguished Member (6.3K reputation)

Group: Forum Members
Last Active: 23 minutes ago
Posts: 1.6K, Visits: 13.6K
Eureka

Thank you so much guys thank you TonyDprime, Justaviking, Animagic, 4u2ges, Dr Nemesis, it was fullscreen render, now it's better, thank you all. I love this community Smile

But RL should resolve this  because if this options are there they shouldn't give that kind of issue

This is a work for a professional singer's clip video about misery, sadness and hope. I'll show you a part of video. They love it because they have trouble distinguishing the animation from the real, they think working with all a team (it's only me) but I have a great "team" having you all guys

https://forum.reallusion.com/uploads/images/c64a40ec-db23-415c-98b8-90c9.png



     


Edited
3 Years Ago by charly Rama



Reading This Topic