Profile Picture

iClone and facial animations in Unity - still having issues

Posted By ldmarkley Last Year
You don't have permission to rate!

iClone and facial animations in Unity - still having issues

Author
Message
ldmarkley
ldmarkley
Posted Last Year
View Quick Profile
New Member

New Member (87 reputation)New Member (87 reputation)New Member (87 reputation)New Member (87 reputation)New Member (87 reputation)New Member (87 reputation)New Member (87 reputation)New Member (87 reputation)New Member (87 reputation)

Group: Forum Members
Last Active: Last Year
Posts: 8, Visits: 40
After searching the forum it looks like this is a problem that a number of people have had, but I wasn't able to find any concrete solutions.  I have facial animations that I created using Face Puppet in iClone.  I want to be able to use them with the character they're attached to in Unity.  I followed the tutorials for taking the animation clips into 3DExchange...the animations play great there.  But when I import the character into Unity the facial animations won't play.  I've re-rigged the character as humanoid.  I've tried turning on DOF in the retargeting menu.  I tried using Generic and Legacy rigging instead.  Nothing helps.  I'm absolutely at my wits end here...I went with iClone because after watching the videos it looked like there would be a seamless transition between it and Unity but it feels like it's been an uphill battle.
ldmarkley
ldmarkley
Posted Last Year
View Quick Profile
New Member

New Member (87 reputation)New Member (87 reputation)New Member (87 reputation)New Member (87 reputation)New Member (87 reputation)New Member (87 reputation)New Member (87 reputation)New Member (87 reputation)New Member (87 reputation)

Group: Forum Members
Last Active: Last Year
Posts: 8, Visits: 40
Replying to my own post to note that it looks like whatever's going sideways is actually a 3DExchange issue not a Unity issue necessarily.  I reimported my FBX into 3DExchange and the facial animations don't appear to have "stuck" to the character because now they won't play here either.
roliveri9031
roliveri9031
Posted Last Year
View Quick Profile
New Member

New Member (73 reputation)New Member (73 reputation)New Member (73 reputation)New Member (73 reputation)New Member (73 reputation)New Member (73 reputation)New Member (73 reputation)New Member (73 reputation)New Member (73 reputation)

Group: Forum Members
Last Active: Last Year
Posts: 5, Visits: 52
May or may not be your issue back I had somewhat the same issue. Make sure when you export from 3dExchange that you have your animation also in this section. I will link a picture to show what I mean. If something is in the Motions Library and not in the Perform Editor Unity will not be able to use the animation on the model even though it sees it. And yes those took me a bit to figure out as well no idea why it is like this but whatever. Hope this helps. GL Smile
Attachments
pic to help.png (29 views, 9.00 KB)



Reading This Topic