Profile Picture

QT updates

Posted By RobertoColombo Last Week
You don't have permission to rate!
Author
Message
RobertoColombo
RobertoColombo
Posted Last Week
View Quick Profile
Distinguished Member

Distinguished Member (6.4K reputation)Distinguished Member (6.4K reputation)Distinguished Member (6.4K reputation)Distinguished Member (6.4K reputation)Distinguished Member (6.4K reputation)Distinguished Member (6.4K reputation)Distinguished Member (6.4K reputation)Distinguished Member (6.4K reputation)Distinguished Member (6.4K reputation)

Group: Forum Members
Last Active: 4 hours ago
Posts: 1.6K, Visits: 3.0K
Hello RL,

I need some guidelines about whether should I update the QT Creator or not.
I get the message that a new version is available but i have no idea whether by updating it I will break the compatibility with Python API system,
Perhaps it will not, because at the end the file is a XML-like piece of text, with some strings identifying the various widgets, and I do not expect to see differences there, but who knows ?
Can you let me know what should I do ?

Thanks
Regards

  Roberto



My PC:
OS: Windows 10 Pro English 64-bit / CPU: Intel i7-9700 3.6GHz / MB: ASUS ROG Strix Z390  RAM: 32GB DDR4 2.6GHz / HD: 2TB+3TB  /  
SSD: 2x512GB Samsung 860 EVO / 
VB: Palit GTX2080 TI GamingPro 11GB / AB: embedded in the MB and VB (audio from the VB with an HDMI splitter) / DirectX: 12

Edited
Last Week by RobertoColombo
The-any-Key
The-any-Key
Posted Last Week
View Quick Profile
Veteran Member

Veteran Member (550 reputation)Veteran Member (550 reputation)Veteran Member (550 reputation)Veteran Member (550 reputation)Veteran Member (550 reputation)Veteran Member (550 reputation)Veteran Member (550 reputation)Veteran Member (550 reputation)Veteran Member (550 reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 110, Visits: 618
I think it's best to follow the API requirements page. Ex:
http://manual.reallusion.com/iClone/script/python/
Say you should have QT 5.6.2
Then you should aim to have that version. There is no point to update for two reasons.
1# Because that could break your .ui files so they become incompatible with the current API.
2# The new features in QT will not matter. Because the API is not designed to use the new features.

My recommendation is to stick with the recommended version.



iClone 7, 3DXchange 7 Pipeline, CC3 Pipeline, CT8 Pipeline, Iray, Live Face, iPhone Xr, Win 10, i9 9900K ~5GHz, Nvidia RTX 2080 8GB, 16GB Ram, M.2 SSD
RobertoColombo
RobertoColombo
Posted Last Week
View Quick Profile
Distinguished Member

Distinguished Member (6.4K reputation)Distinguished Member (6.4K reputation)Distinguished Member (6.4K reputation)Distinguished Member (6.4K reputation)Distinguished Member (6.4K reputation)Distinguished Member (6.4K reputation)Distinguished Member (6.4K reputation)Distinguished Member (6.4K reputation)Distinguished Member (6.4K reputation)

Group: Forum Members
Last Active: 4 hours ago
Posts: 1.6K, Visits: 3.0K
HI,

yes, I agree and that´s what I did: no update Wink

  Roberto


My PC:
OS: Windows 10 Pro English 64-bit / CPU: Intel i7-9700 3.6GHz / MB: ASUS ROG Strix Z390  RAM: 32GB DDR4 2.6GHz / HD: 2TB+3TB  /  
SSD: 2x512GB Samsung 860 EVO / 
VB: Palit GTX2080 TI GamingPro 11GB / AB: embedded in the MB and VB (audio from the VB with an HDMI splitter) / DirectX: 12

luke (RL)
luke (RL)
Posted Last Week
View Quick Profile
Junior Member

Junior Member (181 reputation)Junior Member (181 reputation)Junior Member (181 reputation)Junior Member (181 reputation)Junior Member (181 reputation)Junior Member (181 reputation)Junior Member (181 reputation)Junior Member (181 reputation)Junior Member (181 reputation)

Group: Power Developer
Last Active: 2 days ago
Posts: 105, Visits: 3.2K
Yes, please stay on 5.6.2, this is the version iClone using. If you using another version we can't guarantee compatibility.



Reading This Topic