Profile Picture

IC7.1 - Keys split with move on existed projects

Posted By 4u2ges 5 Years Ago
You don't have permission to rate!
Author
Message
4u2ges
4u2ges
Posted 5 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 4.2K, Visits: 14.3K
The keys are getting split with move on any of my existing projects. Particularly a copy of the torso key is left behind. For now I just delete them (not sure if it is safe).
But working on existing projects is quite annoying, specially if you try to move multiple keys.
I cannot replicate that on new projects though.

Is anyone else getting the same?




UPDATE: Figured it out! Some tracks were influenced by newly installed Curve Editor!

The fix to the problem if you ever experience it:
Right click on the affected track > Curve Editor > Convert to Curve Data

After this option was applied it turned gray (no longer can be selected).
So if it is available, then the track is affected by "split-key" effect as I call it.

I am yet to start using Curve Editor and figure what "
Convert to Curve Data" option is actually intended for.








Edited
5 Years Ago by 4u2ges
mark
mark
Posted 5 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (11.3K reputation)Distinguished Member (11.3K reputation)Distinguished Member (11.3K reputation)Distinguished Member (11.3K reputation)Distinguished Member (11.3K reputation)Distinguished Member (11.3K reputation)Distinguished Member (11.3K reputation)Distinguished Member (11.3K reputation)Distinguished Member (11.3K reputation)

Group: Forum Members
Last Active: 2 hours ago
Posts: 4.7K, Visits: 15.1K
I can't seem to replicate that issue but I can't seem to CTRL L Mouse drag to duplicate a single  keyframe like Torso or Head anymore like I used to.

P.S. The more I play with it ...sometimes it duplicates and sometimes it doesn't ...at least for me!!!
Legacy project scenes with avatars seem to allow "CTRL L Mouse drag-duplicate" just fine but newly created project's with avatar's won't allow me to "CRTL L Mouse drag" to duplicate a key  or duplicate/paste a key anyway I try like CTRL + C or CTRL + V

THESE are CC avatars


PROMO-BACK2
Click here to go to my YouTube Channel filled with iClone Tutes and Silly Stuff

Visit ANIMATED PROJECTIONS Powered by iCLONE

Intel Core i7 3960X @ 3300MHz Overclocked to 4999.7 MHz Sandy Bridge 24.0GB DDR3 @ 833MHz Graphic Display HP ZR30w 
GeForce GTX 980Ti 6GB  Microsoft Windows 7 Professional 64-bit SP1 ASUSTeK COMPUTER INC. P9X79 WS (LGA2011)



Edited
5 Years Ago by mark
4u2ges
4u2ges
Posted 5 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 4.2K, Visits: 14.3K
Thanks for looking into it Mark. I got some new data. It is actually persistent on some of the old projects.
Projects created in IC6 are not affected at all and about 50% of IC 7.0 - 7.02 projects are affected/infected with this "virus".
It is not avatar related. If I bring a new avatar into affected project and create some key-frames they are all OK.
But If I replace affected avatar with any other it inherits this bizarre behavior. And I cannot see any clear pattern.

As to replicating keys with Ctrl + L-mouse as you mentioned, I get this sometimes. There is something wrong with torso key data I think.
A lot of times replicating torso key ended up replicating some other random bones like arm or head. And moreover iClone crashes a lot
on replicating, copying or deleting keys.

RL made a huge investment into timeline amendment and improvement. So this sorts of bugs are unavoidable I suppose. Hope it all would be fixed and cleared in the next update.




Jfrog
Jfrog
Posted 5 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (4.2K reputation)Distinguished Member (4.2K reputation)Distinguished Member (4.2K reputation)Distinguished Member (4.2K reputation)Distinguished Member (4.2K reputation)Distinguished Member (4.2K reputation)Distinguished Member (4.2K reputation)Distinguished Member (4.2K reputation)Distinguished Member (4.2K reputation)

Group: Forum Members
Last Active: 11 minutes ago
Posts: 595, Visits: 4.2K
When copying and pasting transform keys, I had a problem at least 20 times in two days. but a bit different than yours. Basically the second key position where i want to past my transform key get stuck to my mouse and is dragged along while moving the mouse. I use many undos while working. This is with an Iclone 7.02 project I am finishing.

Ryzen R9 5950x, RTX 3090, 128Gb Ram ,2 x 2 TB Samsung 980 Pro M.2 SSD

Immersive Sound VR on Oculus TV
Edited
5 Years Ago by Jfrog
4u2ges
4u2ges
Posted 5 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 4.2K, Visits: 14.3K
I think this is a little different Jfrog. Ok, here is a small project I am having a problem with. See if anyone else is having the same.

1. Bring Katie to the timeline
2. Move any of her bones
3. Move newly created key along the timeline
4. Tell me what happens
5. Alternatively, double-click at any existed key root to fill the hollow and again move that key along the time line.

Katie-walk







Rampa
Rampa
Posted 5 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (32.9K reputation)Distinguished Member (32.9K reputation)Distinguished Member (32.9K reputation)Distinguished Member (32.9K reputation)Distinguished Member (32.9K reputation)Distinguished Member (32.9K reputation)Distinguished Member (32.9K reputation)Distinguished Member (32.9K reputation)Distinguished Member (32.9K reputation)

Group: Forum Members
Last Active: 5 hours ago
Posts: 7.9K, Visits: 54.0K
A hollow key is when there is data on fewer then the XYZ tracks for that body part at that frame. A solid key means there is data for all 3. That's normal. You often want transform data only on x, for example. So when you double-click, you are actually creating a new key at the same time. Try doing your process without adding a solid key first.
4u2ges
4u2ges
Posted 5 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 4.2K, Visits: 14.3K
Well, that is the thing Rampa, whether I create a new key (which is hollow by default) or double-click on existed one within attached project, the result is always the same. As I move that key along the timeline, it splits leaving a single hollow torso key behind. Always! I do not really care about attached project. I posted only for someone to test it. 
But I am currently working on a large project , which behaves exactly the same. Most annoying!



Rampa
Rampa
Posted 5 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (32.9K reputation)Distinguished Member (32.9K reputation)Distinguished Member (32.9K reputation)Distinguished Member (32.9K reputation)Distinguished Member (32.9K reputation)Distinguished Member (32.9K reputation)Distinguished Member (32.9K reputation)Distinguished Member (32.9K reputation)Distinguished Member (32.9K reputation)

Group: Forum Members
Last Active: 5 hours ago
Posts: 7.9K, Visits: 54.0K
It may very well be just cleanup issue too. It might be drawing an extra key that is actually empty. Makes the timeline a little more cluttered. Have you found that it actually does anything? I would just delete them too. Smile
justaviking
justaviking
Posted 5 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)Distinguished Member (19.3K reputation)

Group: Forum Members
Last Active: Last Month
Posts: 8.2K, Visits: 26.4K
I've had "empty" keys left behind, too.  The hollow one that indicates a partially keyed frame, except the frame is actually empty and has no real keys in it.

I don't believe they cause any harm, but it does add clutter and "concern," so hopefully it gets fixed in a future patch.



iClone 7... Character Creator... Substance Designer/Painter... Blender... Audacity...
Desktop (homebuilt) - Windows 10, Ryzen 9 3900x CPU, GTX 1080 GPU (8GB), 32GB RAM, Asus X570 Pro motherboard, 2TB SSD, terabytes of disk space, dual  monitors.
Laptop - Windows 10, MSI GS63VR STEALTH-252, 16GB RAM, GTX 1060 (6GB), 256GB SSD and 1TB HDD

4u2ges
4u2ges
Posted 5 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)Distinguished Member (16.1K reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 4.2K, Visits: 14.3K
No they do not do anything - empty. That is what I do - keep deleting them, but sometimes I forget and my timeline becoming one big mess... Blink







Reading This Topic