Profile Picture

Simply cannot get a usable frame rate.

Posted By Geoffrey James 2 Years Ago
You don't have permission to rate!
Author
Message
Geoffrey James
Geoffrey James
Posted 2 Years Ago
View Quick Profile
Veteran Member

Veteran Member (659 reputation)Veteran Member (659 reputation)Veteran Member (659 reputation)Veteran Member (659 reputation)Veteran Member (659 reputation)Veteran Member (659 reputation)Veteran Member (659 reputation)Veteran Member (659 reputation)Veteran Member (659 reputation)

Group: Forum Members
Last Active: 2 days ago
Posts: 73, Visits: 262
With the Logitech Ultra Pro, I could get up to 40FPS but no faster. I returned that camera for the (here) recommended replacement, the 922C. The fastest it will run is 15FPS, regardless of the settings. Any suggestions? 

Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz, 4001 Mhz, 4 Core(s), 8 Logical Processor(s), 32G RAM
NVIDIA GeForce GTX 1080, 8MB




Geoffrey James
Intel Core i9-9980XE 18 Cores @ 4.5GHz, 128GB @ 3000MHZ, 2 NVIDIA® TITAN RTX, 512GB SSD, 2TB SSD, 10TB HDD, 1200 Watt PS, Viewsonic 43" 4K. 
TonyDPrime
TonyDPrime
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)Distinguished Member (4.8K reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 1.7K, Visits: 5.5K
This has to be the most frustrating, annoying, and most bizarre element of the C922x. 
It has this to-be-side-installed settings manager called "Logitech Gaming Software"

Get it here:
http://support.logitech.com/en_gb/downloads

And look at this webpage for the option called "Low Light Compensation".  You want to turn it OFF (unchecked).  By default it is on.
http://support.logitech.com/en_gb/article/Customize-the-C922-Pro-Stream-webcam-with-Logitech-Gaming-Software?product=a0q3100000B2PiyAAF

Keep in mind that by doing so you need more natural light in your environment as the cam is not processing a heightened lighting sensor....
But, who cares!   As you will soon discover, it gives you the 60 FPS option you want in the top-2 1080p and 720p settings (MJPG). 

PS - Thanks Logitech for making this an annoyingly bizzare PIA.



Kelleytoons
Kelleytoons
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)

Group: Forum Members
Last Active: 4 hours ago
Posts: 5.9K, Visits: 11.9K
Also enable Optimization (so it is only set for 640x320) in the FW settings.



Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
raxel_67
raxel_67
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (1.8K reputation)Distinguished Member (1.8K reputation)Distinguished Member (1.8K reputation)Distinguished Member (1.8K reputation)Distinguished Member (1.8K reputation)Distinguished Member (1.8K reputation)Distinguished Member (1.8K reputation)Distinguished Member (1.8K reputation)Distinguished Member (1.8K reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 534, Visits: 1.8K
Also you should try updating your usb drivers
animagic
animagic
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (19.2K reputation)Distinguished Member (19.2K reputation)Distinguished Member (19.2K reputation)Distinguished Member (19.2K reputation)Distinguished Member (19.2K reputation)Distinguished Member (19.2K reputation)Distinguished Member (19.2K reputation)Distinguished Member (19.2K reputation)Distinguished Member (19.2K reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 11.3K, Visits: 19.5K
I  have found with the Logitech c920 that it will not function well when connected to a USB 3.0 port. Even though manufacturers (including Logitech) claim USB 3.0 compatibility that is not always the case. So check your ports.


https://forum.reallusion.com/uploads/images/1a09220f-ab50-42ac-ad1a-33ec.pnghttps://forum.reallusion.com/Uploads/Images/d14339d0-cd32-4b35-88f9-40a0.png


theschemer
theschemer
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)

Group: Forum Members
Last Active: Last Year
Posts: 1.3K, Visits: 2.6K
I am only able to get 30 FPS out of my C922x but it works ok. I have the optimization on and the low light on but it doesn't matter either way. I found messing with the brightness in the advanced panel (turning it down) helped. I am hoping to get 60 FPS but wanted to ask if anybody getting 60 FPS is on Windows 7 or if that would even make a difference?

Kelleytoons
Kelleytoons
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)

Group: Forum Members
Last Active: 4 hours ago
Posts: 5.9K, Visits: 11.9K
You need low light OFF not on -- are you SURE you have it unchecked?

That's usually the answer.



Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
theschemer
theschemer
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)

Group: Forum Members
Last Active: Last Year
Posts: 1.3K, Visits: 2.6K
Kelleytoons (10/8/2017)
You need low light OFF not on -- are you SURE you have it unchecked?

That's usually the answer.


Yes, it works way better with it unchecked but still can only get a max of 30 fps. I find if I turn down the brightness is works better than the default settings too. I have a few small lights and when I aim them to light up my face the camera loses the tracking and is worse than when I have low light conditions. And in the Faceware software I cannot choose the resolution so it just defaults to 640 x 480. How/when can you change that setting? I also noticed that at 15 fps it sometimes track real well but I am sure I want more fps than that for better results.

Kelleytoons
Kelleytoons
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)Distinguished Member (18.9K reputation)

Group: Forum Members
Last Active: 4 hours ago
Posts: 5.9K, Visits: 11.9K
I think that's odd -- something seems wrong.  My lighting is piss poor (just a light off to one side that doesn't even hit my face) and I easily get 60fps.  But you DO have to turn optimization on (and it should show 640x320  - not sure why the 480 is showing).

My gut tells me there is something wrong with your USB -- I would unplug EVERYTHING and only have the webcam plugged in, just to see (and you ARE using USB 3.0 ports, right?)



Alienware Aurora R7, Win 10, i7-8700k, 4.7GHz CPU, 32GB RAM, GTX Titan XP (12GB), Samsung 960 Pro 2TB M-2 SSD, TB+ Disk space
Mike "ex-genius" Kelley
theschemer
theschemer
Posted 2 Years Ago
View Quick Profile
Distinguished Member

Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)Distinguished Member (4.3K reputation)

Group: Forum Members
Last Active: Last Year
Posts: 1.3K, Visits: 2.6K
Kelleytoons (10/8/2017)
I think that's odd -- something seems wrong.  My lighting is piss poor (just a light off to one side that doesn't even hit my face) and I easily get 60fps.  But you DO have to turn optimization on (and it should show 640x320  - not sure why the 480 is showing).

My gut tells me there is something wrong with your USB -- I would unplug EVERYTHING and only have the webcam plugged in, just to see (and you ARE using USB 3.0 ports, right?)


I switched to USB 2.0 based on a post here somewhere to see if that would help. I will try the USB 3.0 port and see if it helps. I have a couple of hubs connected for various devices (one 2.0 and one 3.0) and they are Plugable brand and are very reliable. But something is definitely wrong. I will post back after some more testing after I switch the USB cable to a direct pc connection on a USB 3.0 port.




Reading This Topic