Profile Picture

UE4 Import - Hair and Eyelashes problem

Posted By afcfonseca93 2 Years Ago
You don't have permission to rate!
Author
Message
afcfonseca93
afcfonseca93
Posted 2 Years Ago
View Quick Profile
Senior Member

Senior Member (272 reputation)Senior Member (272 reputation)Senior Member (272 reputation)Senior Member (272 reputation)Senior Member (272 reputation)Senior Member (272 reputation)Senior Member (272 reputation)Senior Member (272 reputation)Senior Member (272 reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 2, Visits: 35
Hi, I am recently started experimenting with the iClone tools. I am trying to export a character to UE4 but I am having problems with both the hair and eyelashes. At first they didn't appear at all. So I tried to follow the youtube tutorial "Character Creator to Unreal Part 4" and changed the materials to be two sided and with a mixed blend mode but the hair and eyelashes still look incorrect. I have tried to fix this by experimenting with multiple option in the materials but to no avail.

Here is a screenshot of the current hair and eyelashes:
https://forum.reallusion.com/uploads/images/36b3f21f-7481-448f-ace5-804a.png

and here is the current material for the hair:
https://forum.reallusion.com/uploads/images/0d6c97f3-ef76-40bc-a4a1-6001.png

EDIT: Forgot to say, the hair is supposed to be black.
Edited
2 Years Ago by afcfonseca93
afcfonseca93
afcfonseca93
Posted 2 Years Ago
View Quick Profile
Senior Member

Senior Member (272 reputation)Senior Member (272 reputation)Senior Member (272 reputation)Senior Member (272 reputation)Senior Member (272 reputation)Senior Member (272 reputation)Senior Member (272 reputation)Senior Member (272 reputation)Senior Member (272 reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 2, Visits: 35
Ok, I finally have some idea of what is going on. I tried to import to Maya instead of Unreal and I had an extra texture, the opacity texture. When I applied it to the Unreal Engine model with blend mode as translucent it worked. I went back to import settings for Unreal in 3DXChange and I saw that the merge opacity to diffuse option is activated. Strangely using the alpha Chanel for transparency as I had already tried multiple times seems to not work. Is there something I am doing wrong or is this a problem with 3DXchange? I am leaning towards my fault since I am very new to this kind of work and many people probably tried to do what I am doing right now.
Edited
2 Years Ago by afcfonseca93
zelodonio1
zelodonio1
Posted 2 Years Ago
View Quick Profile
Junior Member

Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)Junior Member (248 reputation)

Group: Forum Members
Last Active: Last Year
Posts: 6, Visits: 57
When you import a model; for example from Daz into 3DxChange, I find the eyelashes totally solid. The fix for me is to find the eyelashes tiff in the FBX folder that Daz exported and convert it to a targa file. For some reason 3DxChange doesn't like tiff files. Hope this helps!
ca.rizzgaming
ca.rizzgaming
Posted Last Year
View Quick Profile
New Member

New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)

Group: Forum Members
Last Active: Last Year
Posts: 2, Visits: 4
 I made a tutorial that covers hair material blueprint basics in UE4 to get a pretty good result, hope it helps!

https://www.youtube.com/watch?v=NDbCkHcTQ88&feature=youtu.be



Reading This Topic